PDA

View Full Version : Subdivision order problem Please help!



Ge4-ce
11-15-2004, 11:00 AM
Ok.. I have a character with morphmaps for the facial expressions, and completely setup with bones and IK for the arms etc.

If I turn with the arms, I get a weird deformation of the shouldpolygons. This deformation is gone when I set the object's subdivison order to "After Morphing" or "First". Then it looks like it should be. But when I put it to these settings, my Morphmaps will no longer work! (and presumable sasquatch later on)

What is going on here? Is there something changed in LW 8? or am I missing something completely!

Thanx in advance!

Dodgy
11-15-2004, 06:03 PM
Your morph maps will still work, it just means they'll be smoothed out (which looks better in 99% of cases for facial animation) after the points have been morphed. Everything is groovy :)

Ge4-ce
11-16-2004, 01:54 AM
Oh, sorry.. I explained it not good I see now..

Yes, my morphmaps will still work, but when the subdivision order is set to First, or After morphs, when I apply a morph, it looks like only the points move. The mesh doesn't come with it. It looks like the SD is done BEFORE the Morph.

This is a lose lose situation at the moment. Or my bones cause incorrect deformations, or my morphmaps cause them. There is no compromise in SD order that allows me both!

I looked for plugin-order on my object. But I cannot find them. Where should I look? There is no specific plugin that I added. But I know LW adds them automatically sometimes. (Like Motiondesigner for example) Maybe it's the order in wich these plugins are stacked that causes the problem.

But in object/properties/deform I can only find morphmaps.
I cannot find other plugins applied on the object..

Any ideas?