View Full Version : Modeler Crash: PC/Win2k Hidden Line perspective

10-20-2004, 03:55 PM
I tried NewTek's tech support but they could not duplicate this bug, I'm wondering if one of you could load up the Ferrari Spider model and do like I suggest below (1., 2., 3, ...) and see if Modeler crashes too?

I have seen a couple of posts about crashes in Modeler related to the View...perhaps there's a pattern.

Thanks for testing this out


LW 8.0.1 Modeler
Win2k SP4
1gb ram
Athlon 64 cpu
lots of HD space
NVidia Ti4400 61.77

1. Launch Modeler
2. Load sample "Vehicles\spider_metallic.lwo" object
3. Enable Hidden Line mode for perspective view
4. Move and rotate perspective view so that you can zoom THROUGH the car model.
5. Proceed zooming THROUGH the car model. Go slowly.
6. Your camera view will go through the hood, into the cabin or trunk.
7. At some inner portion of the car, Dr. Watson will say the
application has crashed.
8. Takes down hub.exe and lightwav.exe too.

A) Could only get it to happen in Hidden Line perspective mode, tried
a few others briefly and it worked perfectly.

B) Could only get it to crash, that I could tell, when viewing the
model in perspective from WITHIN the model; that is, you zoom into the
model and are looking around the cabin or trunk and it crashes.

C) Sometimes I have to zoom inside and outside of the car repeatedly
to get the crash.

D) It's a very sexy car model!!!!

E) Looking through the crash log (pasted in full later) it looks like
"DrvSetPixelFormat" was the function that crashed (some Windows
function that google seems to indicate many apps crash inside):

09f9f2fb 85c0 test eax,eax
09f9f2fd 743a jz DrvSetPixelFormat+0x1a6919 (09fa7e39)
09f9f2ff 8babbcff0300 mov ebp,[ebx+0x3ffbc]
09f9f305 0fafee imul ebp,esi
09f9f308 03ed add ebp,ebp
09f9f30a 03ed add ebp,ebp
09f9f30c 8bcd mov ecx,ebp
09f9f30e 8bd1 mov edx,ecx
09f9f310 c1e902 shr ecx,0x2
09f9f313 8bf0 mov esi,eax
FAULT ->09f9f315 f3a5 rep movsd ds:0a360000=????????
09f9f317 8bca mov ecx,edx
09f9f319 83e103 and ecx,0x3
09f9f31c f3a4 rep movsb ds:0a360000=??
09f9f31e 8b83b0ff0300 mov eax,[ebx+0x3ffb0]
09f9f324 8b48fc mov ecx,[eax+0xfc]
09f9f327 51 push ecx
09f9f328 ff15f42b100a call dword ptr [0a102bf4]
09f9f32e 8b74241c mov esi,[esp+0x1c]
09f9f332 8b7c2414 mov edi,[esp+0x14]
09f9f336 83c404 add esp,0x4
09f9f339 8b4c241c mov ecx,[esp+0x1c]

Full Dr. Watson log:

= SNIP ================================================== =====

Application exception occurred:
App: (pid=1452)
When: 10/14/2004 @ 23:06:42.781
Exception number: c0000005 (access violation)

*----> System Information <----*
Computer Name: WAVEMASTER
User Name: Administrator
Number of Processors: 1
Processor Type: x86 Family 15 Model 12 Stepping 0
Windows 2000 Version: 5.0
Current Build: 2195
Service Pack: 4

.... snipped

10-22-2004, 02:15 PM
Try updating your drivers to 66.72 (available on guru3d.com) or later. I used to get the same thing from time to time until 66.72 came out.

10-22-2004, 02:55 PM
Thanks Jamie, I will try this & post again if it doesn't work.