PDA

View Full Version : crawling textures....???!



14DrunkenMonkey
10-08-2004, 01:52 PM
Hi... I am working on an animation...

There is an object to which I've applied a "leather" texture map in the color node... as a Front projection map.

When I animate it the leather texture moves instead of sticking to the object... I can't remember how this is solved. Can anyone assist me?

marek marciniak

toby
10-08-2004, 02:04 PM
Are you animating the camera or the object? Front projection map isn't meant for objects that are animated - If it's the camera, try Sticky front projection map, I think it uses the camera's position at frame 0 even when you move it.

14DrunkenMonkey
10-08-2004, 02:18 PM
I'm animating the camera. The oblect moves slightly, but I can tell that the texture movement is caused by the camera changing locations.

Also, where is the "Sticky front projection"... I can't locate that option.

thanks. mm


Are you animating the camera or the object? Front projection map isn't meant for objects that are animated - If it's the camera, try Sticky front projection map, I think it uses the camera's position at frame 0 even when you move it.

toby
10-08-2004, 02:38 PM
Sorry - it's now called 'Fixed Projection', it's a checkbox next to where you set it to 'Front'

14DrunkenMonkey
10-08-2004, 05:06 PM
Thanks. I had fixed projection checked, but it still went nuts :) I just settled for a procedural texture... still came out nice.


Sorry - it's now called 'Fixed Projection', it's a checkbox next to where you set it to 'Front'

toby
10-08-2004, 09:42 PM
You can also clone the camera and move the one that's not projecting. I had some problems last time I tried though, but I hear that keeping the two camera resolution and zooms identical solves that ~