View Full Version : exporting dynamic VRML from LW

04-06-2003, 10:01 AM
I'm currently doing a project for uni and am using LW to create and export VRML objects.
I can export static objects quite ok with the LW VRML exporter, but have not been able to export any dynamic VRML objects. i.e. I can't export any animations done with bones or with morph targets.

If there's anyone who's versed in the VRML exporter I'd be happy to get some tips.

A small sample:

Arnie Cachelin
04-06-2003, 01:03 PM
In order to get morph or bone animation into VRML, the vertex animations need to be recorded into VRML morphs. You can do this from the ExportVRML plugin in layout. It is under the Objects tab. For this to work, you will need to use prototypes AND embed the objects in the scene.

04-06-2003, 02:17 PM
Thank you Arnie but that doesn't seem to be working for me. I've tried that before (and once again after your reply) but I still can't get any motion.

I've opened the VRML file in notepad to have a look and it seems to have recorded the bone movements in there but when I view the file regularly no motion occurs.

I've tried playing with the triggers too but to no avail.

Arnie Cachelin
04-07-2003, 06:05 PM
Are you able to get regular keyframed animation working for thie object? What browser are you using?

04-10-2003, 10:40 AM
been away for a couple of days

I've tested regular keyframed animation and it's working fine (with and without prototypes)

I'm using Cortona VRML 4.0. However this is for a University project and the programmer actually exports the VRML into Open Inventor (http://oss.sgi.com/projects/inventor/) which is why I am loathe to use prototypes (he can't translate them properly).
He also cannot get any animation out of my VRML files.

Thanks for your time and help

Arnie Cachelin
04-12-2003, 03:40 PM
Using protos is really necessary to get the CoordinateInterpolators to work.

04-12-2003, 08:50 PM
the morphs and bones don't work even with the protos.

04-20-2003, 03:20 PM

04-26-2008, 06:33 PM
I am having the same problem. What do you mean exactly by "prototypes" ?

04-26-2008, 06:35 PM
OK I see the prototypes selection. Still not working. I'm trying to bake the motion but it doesn't seem to work either.