PDA

View Full Version : Lightwave layout [8] Display speed



sectora
09-28-2004, 01:23 PM
Hi all,

Since I upgraded to Lightwave [8] I have found that I cannot sensibly work in Layout because any interactive operation (rotating, panning and zooming views) just stutters along...

When nothing is selected the speed is just fine but as soon as something is selected, be it a camera, a light, a model or bone or anything the interaction grinds to almost a full stand still.

I am runinng Lightwave [8] on a G4 powerbook 1.25Ghz with 1gb of ram.

Any suggestions?

Thanks!

Albert

http://www.sectora.net

noiseboy
09-29-2004, 01:50 AM
Have you tried switching off all the extra funky Opengl options in the cleverly named Options panel, if you have Sub-d objects lower the display level. I've got LW8 running on a 867Mhz G4 12" laptop, while its not great its usable with smaller scenes. even with shaded views. You dont mention which OS X flavour you are running, that might make a difference if the graphics drivers have been updated.

sectora
09-29-2004, 02:02 AM
Hi Noiseboy,

Actually all the fancy options are switched of. And to top it... there is nothing in the scene except a camera and a light. It's just the default empty scene that opens when Lightwave Layout starts up.

again the interaction is just fine UNTIL I select either camera or light icon. Then it starts to stutter tremendously.

I run OS X 10.3.5

Albert

noiseboy
09-29-2004, 05:19 AM
cant suggest anything else, except the usual repair permissions, delete preferences type stuff. I'm sure there are a couple of people on these forums running the similar hardware, policarpo for example, and if it was an issue with LW8 I would have thought someone else would have piped up by now. Sorry I cant be more helpful

eblu
09-29-2004, 08:40 AM
i know it seems like you shouldn't Have to do this, but try deselecting everything. some things like object xforms you just have to have something selected, but for moving around in the workspace, you just don't need anything selected, so why do it if it slows you down?

LW has always slowed down while something in camera was selected. Its probably worse on the marginally supported hardware (like the mobility graphics cards) but it ALWAYS happens on every platform. On macs its much worse than it is on PCs, but its still there. Apparently LW uses the processor heavily while redrawing ANYTHING that is selected, whether its changing or not. So the best solution, and the most direct answer is to deselect all objects before you move around.

ok I know I know... LW doesn't like to have Nothing selected. It has philosophical issues with nil, Null, and zero. so what can we do? select something out of view, such as a light, or an object that you just won't be looking at. LW ignores objects it doesn't see when redrawing, and its essentially the same as having nothing selected.

meanlebh
09-29-2004, 07:36 PM
One thing that i have found from time to time is that my bounding box threshold (in the display options box) increases automatically, and it slows the display WAY down.....i lower it again and it works just fine....i usually keep it around 10000, but maybe a different value would work better for you? just a thought, but it is worth a try if you haven't already done so....

sectora
09-30-2004, 12:24 AM
The scene is empty so bounding box threshold should not pose too much of a problem :)

I also tried moving one object, like a null, really very wide out of camera's view but the stuttering persists.