PDA

View Full Version : Issues of dongles and documentation



The Watcher
09-25-2004, 09:16 AM
On the 20th I spent nearly two thirds of my monthly wage on a copy of Lightwave 8 Siggraph Special from a reseller in the UK (trimediaonline.co.uk), when it arrived yesterday I started the install process only to have to run the gauntlet of trying to get the Sentinel driver installed so that the USB dongle would work. This process was far from smooth thanks to the fact that the vital driver in question is not signed so the hardware detection wizard will not show it by default - I had to specify the location by hand.

I had just spent over a thousand UKP on a product and there was no documentation at all about how to get the dongle to work either in the box or as a readme on the CD. Why is there no documentation on the CD about install procedures and driver issues? I provide more than that for my students and they are using simple compilers and CBT packages!

After fiddling around to get the dongle to work, the rest of the install went smoothly and, once the registration was delt with (which I could rant about as well), I was a happy lightwaver. Today I made a couple of bios changes for something else (including disabling the parallel port), went back into windows and started doing some work in layout. Of course, I didn't notice the "Discovery Edition" notice in the titlebar until I tried to save the scene. Why was I not given a warning that Lightwave had not detected the dongle and was starting in crippled mode?

Now, looking at the search on these forums (which is the only way I managed to work out that the dongle drivers are so flakey they will cause this problem, no wonder they aren't signed...), this problem is not uncommon. In fact it seems to make a fairly regular appearance. Yet is there no mention of what can cause the problem, how to fix it and how to avoid it in the Lightwave documentation, support or forum FAQ?!?

I appreciate Newtek need to make a pretence at preventing piracy, but when legitimate users are locked out of the software they have purchased and there is no official information on how to fix the problem I find it insulting and aggravating, especially when work is lost because of it.

I request that whoever is responsible for producing the Program Disk ensure that there is a README.txt file on the CD containing instructions for how to install the Sentinel driver on every operating system Lightwave will run on, a notice informing users about the idiosyncracies of the dongle driver (a search of the forums will produce a list of common triggers for problems) and instructions for how to fix the problem if it is encountered. If that isn't possible, put a sticky thread in this forum describing it so that users don't have to dig to discover it.

Oh, and hi everyone, I promise I'll try to make future contributions less caustic ;)

Whit
09-25-2004, 12:24 PM
I've had some of the same frustrations.

It would be very helpful if Lightwave announced that it was starting in Discovery mode with a dialog box.

More prominent, official, discussion of the dongle drivers on Windows would also be helpful.

--Whit

Phil
09-25-2004, 01:09 PM
It annoyed me as well, but someone coded up a freeware plugin called CheckDongle.p that I have installed here. This puts a little message box up when you start Layout or Modeler without the dongle plugged in.

The readme for the plugin doesn't provide any information about the author or where it might be obtained (or if it can be redistributed).

The Watcher
09-25-2004, 02:21 PM
The readme for the plugin doesn't provide any information about the author or where it might be obtained (or if it can be redistributed).
A google doesn't turn up anything either. Well, I intended to see whether I could get the SDK to work with DevCPP anyway, that just gives me a first plugin to write ;)