PDA

View Full Version : LW_TGA24 and Final Cut Pro HD



unc1e meat
09-24-2004, 03:14 PM
I rendered out an animation from Lightwave using the D1 (NTSC) camera settings. I have anti-aliasing on. I rendered it out as a .tga sequence so I can import it into my video editing software which is Final Cut Pro HD. I import the targa sequence and when I open the individual frames in the Final Cut viewer, they look fine. But as soon as I place the sequence onto the timeline for playback of the animation, the picture gets this subtle yet noticeable banding. You see the background of the animation is a gradient from blue to black. There is a background fog applied. I have attached a screenshot of what the banding looks like if wouldn't mind checking it over.

I've checked and double checked to make sure that my timeline settings in Final Cut Pro are for DV NTSC. Also I've made sure that my playback resolution is set to 100%. Still I see the banding on my computer screen. I also viewed on my TV monitor to make sure and it's still there. I can't seem to get rid of the banding! I'm really frustrated and would appreciate any thoughts you may have on how to fix this. Thanks

The_Eye
09-27-2004, 08:30 AM
Sorry, I can't help ya but could you quickly explain how to import TGA sequences in FCP? I don't use it, but I have to give it to someone who does and I was under the impression that it couldn't do that (which I find hard to believe). Maybe it's just 32 bit TGAs? hmmm

Anyway, they have banding on the NTSC monitor, not just your desktop monitor?

monovich
09-27-2004, 11:06 AM
my first guess would be that the DV codec is killing you. Anyone know if DV is 8bit or 10bit? If it's 8bit, that's probably where the banding is coming from. DV almost always looks crappy in the Final Cut preview because it doesn't fully decode it for playback on the computer monitor (but does on the TV monitor). That particular nuisance wouldnt explain your banding, but it's something to be aware of when your work looks like hamburger on your computer monitor.

to import tga sequences, you just set your default still image length to 1 frame, import all the frames and drop them into a sequence, then you drop that sequence into a main editing sequence and treat it as normal footage.

-s

eblu
09-27-2004, 11:25 AM
thats a DV problem unclemeat. the TGA is just fine.
banding is a fact of Life, its a compression/colorspace conversion issue.

the TGA format allows a lossless compression technique, which basically translates into "uncompressed" as far as the data is concerned, thats why the naked TGA looks fine.

when you place it into your Sequence in FCP, you are in essence re-rendering your TGA in whatever format you've set in your sequence settings (this case DV), and thats why it looks good but out of the sequence but in the sequence it doesn't.

DV gets about a second for every 3 megs. this is a huge amount of compression. For comparison consider that a d1 frame, uncompressed, runs around a meg a piece, and there are usually 30 frames in a second... an uncompressed second of D1 video (720 x 486) is 30 megs. Thats a 10:1 ratio, DV looks great for that savings but you Have to lose something to the compression. That could be the root cause of the banding, but it also may not be.

You rendered in RGB colorspace, FCP works in RGB, but the NTSC standard is YUV, and Somewhere in the pipeline you have to convert the RGB Colorspace to YUV before it goes to video. YUV is a strange duck. It has less possible values than RGB, but a wider spectrum. Converting your nice images from RGB to YUV typically adds banding, in areas that have gradients. There are lots of industry experts using very strange math symbols to explain this, so just trust me on this. This is why we use 10 bit files where we can. 10 bit files Do not get rid of banding, they lessen the effect (by offering a more detailed RGB color spectrum to the YUV translation), but it is better than 8 bit RGB files.

so... your banding is caused by :
1. compression
or
2. color space conversion

your choices to get rid of the banding are:
1. re-render in a higher bit depth (ask beamtracer he's figured that out.)
2. use a different compression, or a higher quality setting.
3. redesign the render to use less gradients.

unc1e meat
09-27-2004, 02:34 PM
Wow, thank you. I really appreciate all the help because I was lost as to what to do next. Now I actually have some things I can try. I think I may for now just rerender it without the gradient in the background. I'll still keep the background fog but I'll just use a single color for the background. Hopefully this will make it so the banding isn't so noticeable. I know however that sometime in the future, I'll want to use a gradient again for the background for a different project so I'll also give rendering to 10 bit rgb files a try. Thanks again to all of you for helping me out.

Ryhnio
09-27-2004, 04:19 PM
is the animation scaled out to 100% or 98.9%? (Dv is at 720*480 and Final Cut will scale it down to fit)


-Ryhnio

monovich
09-27-2004, 07:32 PM
Thought of another thing. Final cut is a crappy scaler. If you have After Effects, do your conversion to DV from there, it samples better than final cut.

-s

Avebeno
09-27-2004, 09:48 PM
One trick I've learned is to add a noise filter to the video. A very light setting of noise (3-4%) makes the video look a little more dithered, with less banding when there are problems like this in DV. Let me know if it works for you.