PDA

View Full Version : How do I render glass?



dranos
09-23-2004, 04:11 PM
Hi all,

I have a problem here. I have to recreate an outdoor scene with glass cups on a table. The cups are empty at one stage and the full at the next. The thing is, I can't seem to get the glass to look right. I need to see the background footage through the glass. I tried using the glass preset that comes with Lightwave but I still can't get the right results. I've attached pic to show my predicament. Please help me solve this problem?

Thanks in advance.

Kainlamond
09-23-2004, 04:28 PM
did you turn on "Ray Trace Transparency" in the "Render Options"

dranos
09-23-2004, 04:44 PM
Yes I have all those options checked except for Depth Buffer AA. Another quick question is, should I assign different surfaces for the inside and the outside?

parm
09-24-2004, 12:59 AM
Hi
Check "The Worms of art" website, they have some good tutorials, of particular interest would be the one the fresnel effect:
http://www.the-worms-of-art.com/tutorials/lightwavetutes_221.html
They also have presets for sale, may be useful.
Also, if you include some highly luminous objects in your scene, ( I mean more than 100% luminous), you will get some pretty realistic specular highlighting on your glass.
Hope this helps a little

Parm

Avebeno
09-24-2004, 01:48 AM
Check that in your surface editor, under the Environment tab, Refraction options are set to "Backdrop only", or "Raytracing and backdrop."

Double check that your refraction index under the Basic surface tab <>1.

Under render options, set your "ray recursion limit" to 2 or 3 to start with.

dranos
09-24-2004, 10:57 AM
The tutorial was interesting but it doesn't really solve this particular problem. The glass has to be transparent because in the scene, a child will be behind it waiting for juice to appear in it. So far, the glass reacts to the backgound COLOUR, not the background IMAGE. This scene will have a lot of activity behind the glass. I need the background footage to influence the glass. Is this possible? I have to get it right because this is a critical scene. How does one achieve realistic glass effects like these I found in the gallery? Will I have to get third party plugins? Am I trying to do something that is normally done differently?

monovich
09-24-2004, 12:46 PM
maybe post your file?

other option is to maybe try to put a flat plane facing behind the glasses, then projection map the still onto the plane. I'm sure they'd interact that way. The glass you have in the first frame (bluish one) doesn't look right at all, the glass surface settings look wrong.

you don't HAVE to assign different surfaces to the inside and outside, but if you do, it does usually look a bit better.

the effect you want should be incredibly easy to achieve.

-s

-s

dranos
09-24-2004, 07:25 PM
That is exactly how I feel. I'm sure that I missed something simple. I am posting my file in hopes that someone might get the desired results. I thought of using a flat plane with the footage projected on it in the background but that would be affected by 3D light and shadows and I dcan't have this section of the commercial looking different. I really hope one of you guys can help me solve this problem.

wapangy
09-24-2004, 08:31 PM
Found the Problem

First, Turn OFF Ray Trace Transparency (but don't ask me why)

Second, load a preset for the glass texture (I used #3) because some of your setting are way off, then tweak them for your look. And you can turn off double sided if you don't want to render for ever.

I get this:

wapangy
09-24-2004, 08:42 PM
Also, if you did ever want to put it on a poly in the back, just turn luminosity to 100 and diffuse and the others to 0. And in the object render properties, turn off cast and receive shadow.

mamurphy
09-24-2004, 08:44 PM
It looks to me like Lightwave won't let you use your composited BG image in any sort of reflection of refraction capacity.

You are seeing your background color [cyan] as your transparency, refraction and reflection fills.

The camera is totaly ignoring the background image in the render process.

You can use the image world plug-in, but it looks terrible as that streches the image around 3d space....

You can set this image as your reflection and refraction in the surface editor, but the results are really yucky.

As far as I can tell, the best bet is to link a panel that stays in front of the camera and "plays" your video footage.

That way, at least you will have the refraction and transparency showing the correct image.

dranos
09-24-2004, 10:57 PM
Found the Problem

First, Turn OFF Ray Trace Transparency (but don't ask me why)

Second, load a preset for the glass texture (I used #3) because some of your setting are way off, then tweak them for your look. And you can turn off double sided if you don't want to render for ever.

I get this:

Thanks a million! That did the trick. I'll just do the necessary tweaking to get it just right. I can always count on you guys.