PDA

View Full Version : Help with 'Bubbles' appearing in 'Glass' Object



mamurphy
09-18-2004, 08:38 PM
I am starting a broadcast animation project and I am using a 'Glass' surfaceing on some flying text.

On close up frames the 'glass' looks like it has 'bubbles' in it. I don't want that. Any suggestions or techniques to prevent this?

Here is a frame of the animation:

JamesCurtis
09-19-2004, 10:48 AM
You could model the half sphere waterdrops. However, if your surface is rerlective it still may look bubbly like. Glass actually is fairly low on reflectivity, so keep it's refledctive amount down.

SplineGod
09-19-2004, 11:47 AM
You can check for:
Double polys, nonplanar polys, shadow maps and raytrace settings.
Are you trying to get proper refraction?

mamurphy
09-19-2004, 12:11 PM
There are no non-planars.

Lights have raytraced shadows, but Raytrace shadows are turned off in the render settings.

The other raytrace settings have refraction, reflection and transparency on.

What I did was copy all of my outward facing polys, copy and flip the normals to face inward. Then all inward facing polys were made invisible.

I am trying to make realistic refractions using the following tutorial:


www.3dworldmag.com/stoppress/ realisticglass_tutorial.pdf

SplineGod
09-19-2004, 12:54 PM
Start turning on/off each of those attributes and see which one causes the issues. Did you give each surface an index of refraction?

mamurphy
09-19-2004, 02:32 PM
the outside facing polys have an index of 1.5 and the inward facing have 1.0

I did test each setting and turning off the refraction stopped it, but then I didn't have any refraction :mad:

I don't know what else to do. Fortunately, this isn't going to prevent me from finishing this. I just want to know for future projects where this might cause problems.

Igu4n4
09-19-2004, 08:34 PM
As Larry said,.. the culprits for this are a few possible things.

Double sided polygons are your prime trouble maker. Make sure in your surface attributes that double sided isn't checked. The problem you are having is because there are two polygons sharing the same "computational" space. This is always picked up in refraction because the light doesn't know how to trace properly. (insert techno-engine-coding speak here).

You're using the air layer technique which is a good one, and produces some of the nicest refractions, just make sure that you did indeed flip everything to the right direction and they truely aren't double sided..

Another option you MIGHT want to try... is use SUPERSHIFT and shift the inner polygons (in all directions) by .0001 smaller. This will make sure the surface aren't sharing the exact same positions, but you might get a minor refraction displacement because of it. if you use a number like .0001m you shouldn't notice it. If you SCALE .. your surface will pass through each other, so make sureyou supershift properly.

Steve.
www.iguana-den.com

mamurphy
09-19-2004, 11:02 PM
Hey Igu4n4, thanks for the Supershift suggestion.

That's a LW8 addition, correct? I will have to try that when I go into the office tomorrow.

Only have 7.5 here at the house. LW8 at work. Maybe it's time to upgrade :cool:

Igu4n4
09-21-2004, 08:54 AM
yes, LW8. There's plugins available for LW7.5 that do similar things. Im not sure if Supershift is available anymore due to its inclusion in 8. Check Flay.com. Or ask on the board if anyone has a legacy version.

Steve.

StrongBad
09-21-2004, 12:34 PM
Dear mamurphy,
Love the Avatar.
"Do you like popcicles? I got a whole mess of 'em down in the cellar..."
Brian
Hot Carl Productions