View Full Version : internal buffers too small for requested operation

09-16-2004, 07:46 PM
I get this error from time to time when I try to boolean an object from another. It gives the same error with any of the CSG operations. (Boolean, Solid Drill, Drill etc..). Not every operation.. but seemingly when Im boolean'ing a detailed point object form a simple one.

For example this evening, its giving me one when I try to boolean a 404 point cookie cutter type shape... from a flat oval 24 point object. Should be simple... basically think cutting cookies from dough.

Anyway to bump up these internal buffers? It's really annoying.

or cause of this?


09-17-2004, 11:46 AM
apparently the solution is to save your file, close modeller and reopen your file, and attempt the CSG again... memory leak? buffer not being freed?

bug? (I have seen these through several version of Modeller, however I have seen it crops its ugly little head a few times recently). (8.0.1)


09-17-2004, 02:03 PM
Happend to me too sometimes, its simply bad memory management, one of Lightwaves key features :D

02-09-2005, 09:54 AM
I was having the same problems with booleans, then I changed in General Options the Polygons to Automatic and it seems to fix that. Even, when Polygons was in Quadrangle I tried to do a Boolean Substract of a Box with a sphere, and it kept the outside faces of the box, but when I changed to Automatic, it did it fine. This was with LW 8.2.