PDA

View Full Version : Controlling Surfaces, Set Driven Problem



lord
09-12-2004, 06:44 PM
What's going on here?

I've set up a very simple character, most of it's working fine except for the eyes.

I've set the rotation of their surfaces to be controlled by the rotation of a Null object.

I've tried this two ways, using very simple expressions, and using Set Driven keys motion modifier.

Everything works fine (except for the fact that it dosn't update in the viewport until I scrub the time line) until I close the file and reopen it. I find that the Surface channels have lost their connections to the Null control object in the Set Driven Key modifier properties, and I have to reasign the connections.

I've both saved the scene and Saved All Objects before closing and relaunching LightWave.

Very frustrating.

Anyone know why and how to fix it? I'd really appreciate it.

Cheers,

I'm using LW 7.5c

faulknermano
09-12-2004, 11:48 PM
does this happen with expressions?

Weetos
09-13-2004, 02:21 AM
hmmm not in front of LW right now, but I think you don't need either expressions or any motion modifier... Just use your null as a reference object for your texture (in the texture editor). This will rotate the texture accordingly to the null's rotation

Hope that helps

Regards

Weetos

Oops forgot to mention that you need to move the reference null to the geometric center of the eye ball. Obviously the nulls also have to be parented to the eyes. You can then control the rotation of those nulls with expression (eg by using the HPB channels) or by setting goals for them to point at

lord
09-14-2004, 04:56 PM
Hey thanks for your replies. I was away all of yesterday, recovering from nasty flu.

Dosn't appear to do the same with expressions.
Only Set Driven Key.

And the old reference object in the texture editor was the obvious candidate for the job.

Thanks Weetos, sometimes, when you've got your head down over the keyboard you can't see the forest for the trees.

Weetos
09-15-2004, 05:14 AM
you're welcome ;)