View Full Version : Quadro fx 1000 modeller crash

09-08-2004, 06:43 AM

We recently upgraded our graphics cards to quadro fx 1000's ( from some low spec matrox ones). The speed increase was well worth it, but since the upgrade lw modeller has been a LOT less stable.
The worst problem is the modeller texture crash. Loading textured models into modeller with texture view on is very unstable, and we've got some models that crash Modeller every time unless we switch to smooth shade or lower.
The open gl window occasionally 'forgets' polygons. They can been seen and selected in the other views and exist, just aren't drawn in the 3d view (texture view or not) .

These models loaded fine ( although slowly) on the old matroxs, and we're getting the same error on all 3 cards, so I dont think its dodgy hardware.

I've tried 3 or 4 different driver versions (old and new), with and without the special 'lightwave compatible' option.

Has anyone else had this problem, or know of possible fixes? The texture view is very handy for some of the lopoly work we do and having it switched off is causing problems.

Thanks for any help:)


09-08-2004, 07:11 AM
I suspect you still have remnants of your old driver lingering about.

09-08-2004, 07:24 AM
Thanks for the reply Mattclary, but nope, the machines were all formatted with a fresh install of win2000.

I'll just update this thread with some things I've just managed to rule out as causes. I've got a 12,000 poly model that causes the crash when used in texture view. It uses 1 texture (a 9 meg 24bit png).

Texture size or name (texture has been resized to half and qaurter size/renamed)
Texture also loads and is displayed fine on a simple cube.
Texture mapping (cubic, planar, uv etc all cause the same crash)
drive mapping (copied everything to local)
1,2 point polys
non planar polys

Any other ideas ?

edit: just to be extra confusing. If I load the model with texture view on it crashes. If I delete all the nontextured surfaces of the model and save that as a copy, thatll load. Then...if I dont close modeller, but just load the original straight after it loads ok. WTH is going on there:).
Its looking more and more like an issue with the nvidia drivers :(


09-08-2004, 07:53 AM
What driver number are you using? Go to Nvidia Website and find the latest driver they are recommending with LightWave. I believe it's 53.04, which I'm using with a FX 500. I have no problems whatsoever, and I've loaded a 250,000-poly object in Texture view.

09-08-2004, 10:42 AM
Well, it's hard to follow all that, but it sounds more like some kind of corruption in the model iteslf. It only happens with this one model, right?

09-08-2004, 12:51 PM
Sorry for the late reply,

ColinCohen, I'd tried about 4 versions of the drivers, including those. Just before leaving work I tried the 53.04s again, with no luck:(

Matt, Nope it happens with a fair percentage of our models. The model will also load fine with textured view into layout. Its only ever modeller that has problems.
I spoke to one of our programmers at work and showed him the confusing ' model loads after youve loaded a simpler model with the same textures'. Obviously hes not privy to the inner workings of lightwave, but he said the crash looked like a problem with the program ( or rather how the proggy is working with the drivers), rather than the drivers themselves.
Although what with the occasional invisible polys Im not so sure myself.

The even worse news is we've got 1 copy of lightwave 8, and this problem is still present in that, so even a LW upgrade wont help:/

We dont really want to have to buy new graphics cards straight after upgrading.


ps. Just realised, I havent posted system specs/version of lightwave etc. incase it helps at all.

p4 3gig (ish)
1 gig of ram
quadro fx 1000
lw 7.5 with latest patch ( and version 8 without latest patch)

09-08-2004, 08:23 PM
Matt, Nope it happens with a fair percentage of our models.

OK, think this through logically. What do they all have in common? Are they all native LW models or were they imported from another app? Can you send me a copy of one of the offending models? My e-mail is matt.clary @ comcast.net (remove the spaces).

09-10-2004, 01:10 AM
HI agian matt,

Sorry agian for the late reply. We're snowed under at work and I've been pulled onto other things.
Off the top of my head the only things I've i've noticed in common with the models,
are multiple surfaces, and textured. Polycount doesnt seem to matter.
I honestly don't beleive its anything 'wrong' with the models. They load perfectly on a machine using a different graphics card, and display perfectly in layout. Its only in modeller opengl view , when using that graphics card that we get the crash :(. I think if it was the model it would have the same problem regardless of graphics card, and would aslo probably occur in layout, maybe?
I've also tried exporting them out as lw5 objects and the same error still occurs.

I think it has to be something to do with the way the card is displaying textures when using modeller.

Maybe the number of surfaces has something to do with it.
Im rapidly running out of ideas though:/

Oh yeah I'll see what I can do about getting you a test file, thanks for that:)