PDA

View Full Version : screamernet problems



quatermain
04-02-2003, 03:20 PM
I want to render in the background while still using Layout on a DP Mac. I've set up screamernet, but while it is rendering, I cannot access the properties window b/c it is being used by network rendering. The network rendering window does not close and cannot be replaced by either the object, bones, lights, or camera properties b/c they are not selectable. Is this how Screamernet 'works'? Am I doing something wrong?

System specs: LW 7.5 Mac OS 10.2.4, DP 867

noiseboy
04-02-2003, 03:38 PM
This is what you need,
http://www.catalystproductions.cc/screamernet/
the ScreamerNet Controller will allow you to do exactly what you want, and its free for one Node.

mlinde
04-02-2003, 03:45 PM
You could also use my Launch Mode3 LScript, which has less overhead for a single render on the same machine.
http://home.earthlink.net/~mlinde/lscript.html

quatermain
04-02-2003, 10:16 PM
Thanks a lot guys. screamernet controller helps a lot. And thanks to the author of that app.

Does the multithreading option affect rendering 2 jobs simultaneously with a DP mac in any way? What's the best multithreading setting? I have noticed that the LWSN window won't hide when it is running, which sucks as I only have 1 monitor.

Julian Johnson
04-03-2003, 05:07 AM
Threading's a really odd one. LWSN responds to threading as you'd expect but, overall, its render times seem considerably longer than Layout's. If you use multiple instances of LWSN on a single machine you should set threading to 1. This has been the recommended setup for a while. Be aware that if you set your threading higher than 1 it seems that contention between the threads with multiple LWSNs isn't worth it. Here's a rough table of what I've been getting. I always thought LWSN rendered faster than Layout (would love to know if others get similar figures).

Layout (4 threads): 335s
LWSN x1 (2 threads): 612s
LWSN x1 (4 threads): 500s
LWSN x1 (8 threads): 435s
LWSN x2 (1 threads): 375s
LWSN x2 (2 threads): 610s
LWSN x2 (4 threads): 500s

So, in Mode 2, if you have a dual machine it's a no brainer to use two instances of LWSN with the thread setting at 1. In fact if you use two instances of LWSN on a solitary dual machine with a thread setting higher than 1 you get no benefit at all. If you don't have a dual machine then the normal optimal thread settings for your scene will be appropriate. For Mode 3, the same applies. If you're running Mode 3 it looks like it would be most efficient to run two instances of the Mode 3 render instead of one with a thread setting of 1 (as with Mode 2).

Strange that LWSN seems to render much more slowly than Layout here.

Test Setup: 7.5OSX/DP800/10.2.4/1.5Gig RAM/Raytrace.lws/frames 1 and 2 rendered.

Julian