PDA

View Full Version : TMPGE wont render Project



edmellnik
08-09-2004, 11:49 AM
WEll after months of good rendering projects with TMPGE
I cant get it to load a VT3 project.
something in the plug in must have gotten corrupt.
Everytime I try I get "...blah blah ...unsupported file.

This happend last month and after playing with the settings it
finally loaded...but is is now gone for good.

Anyone have a fix for this or do I have to uninstall everything
and reinstall?

486 RTV files and clipping the bottom 6 lines.

ed

edmellnik
08-09-2004, 03:13 PM
Well I figured out that earlier projects loaded ok in tmpge.
SO I found what project was the one that started not to want to
load in tmpge...(Closing TMPGE and reopening for each try).
Then I figured out the the problem started when
I had projects with the credits on the end of the program.
I took those overlay credits that were CG PNG files and saved them all individually as Tga files.
When I put the Targa files on the timeline and turned overlay on then saved the project . EVERYTHING WAS WORKING AGAIN.
Then I could load in TMPGE And everything was fine.

At first I tried to just render the credit PNG files overlaying the video thinking that I could just take a rendered clip and replace the individual files.......BUT I found the rendering did not work with these PNGs either..it would start rendering then stop short.
Now I had PNG overlays earlier in the project that did not cause a problem so...???what gives.
The only difference I can see is that the credits had graphic lines in the CG Files. I would put say....Written by then a red graphic underline and below the line type the name.
I have not got 100% evidence of this theory because later I tried to take the graphic line out and it rendered fine.

BUt if anyone has this problem I suggest keep trying to
load older and older versions of the project, always closing tmpge and reopening for each attempt till you find a project that loads.
Then figure out what the difference is.
My theory is that when using The PNG files that are created in CG when you save your project are the problem. Not all PNGs.
Maybe only PNGs that have graphic elements like a brush or graphic line in them and then the problem will only come up when trying to overlay them on video.
Andrew should be made aware of the problem.
The problem can be easily seen when you cant even get a proper rendered clip out of the overlays.

SOrry for being so long winded but I can make a file that causes the problem together with the PNGs and send them to someone at Newtek if they want.

ed Mellnik

mgrusin
08-10-2004, 10:16 AM
This EXACT problem has been bugging me a LOT in the last week (I had never seen it before). Thanks for checking into it and coming up with a go/nogo case that can be sent to Newtek!!

My story is that I had a batch of TMPGEnc VT-Edit Project encodes going, and at random(?) points the current and all subsequent projects would fail with "unsupported format" messages, like the VT-Edit Project rendering engine died or something.

I found that if you reboot, all would be well again and it would continue encoding (usually getting through the formerly 'unsupported' file)... But at some further random point, it would fail again. I had lost a few nights of CPU time by this point and had to make a deadline so I finally rendered out the rest of the files to DV just to get them encoded (oh, the horror!).

I figured it was my Windows/VT install going wonky and was making plans to reformat (a day-long PITA). But it could certainly be .PNG overlays; I used them quite a bit in the above projects, and a different set of projects I did last night with no .PNG overlays encoded with no problems.

My problematic projects had .PNG overlays, .RTV+alpha overlays (from LW8), and had stacked (2) overlays. One of them also had a fast-motion sequence. But other than that they were normal DV-2 source files, cuts, fades...

I'll switch to Targa files and see if it helps. Thanks again! Newtek, good luck finding the bug and keep us posted.

-MG.

edmellnik
08-10-2004, 01:01 PM
Well I have not been able to confirm that graphic elements
have any bearing.
After many more tests I can confirm that changing the PNG overlays to Targas fixes the problem.

On the mornings fresh boot even the bad project loaded into TMPGE without a NON SUPPORT error.

but on a second attempt even after closing tmpge and reopening the bad project would not load.

But rebooting the computer does not always fix the problem either.

I would like to know what the difference is between saving as a VT-Edit project and saving as a VT3 project.
When you just do a save as it defaults to a VT-edit project.

ed