View Full Version : Depth Blur Focal Point picker not working??

08-05-2004, 08:13 AM
Ok, I rendered out an image in Lightwave, saved it as an RLA file, and brought it into DFX+.

Im applying the Depth Blur tool, and when i go click and drag the Focal Point picker I get no change at all.. Nada, zilch, zip, zero, nil…

Now, This is the first time that I’ve tried screwing around with the depth blur tool.. Am I missing something so basic?

Ive picked from the original image displayed on the left, Ive picked from the post depth blur image displayed on the right. Heck, I even tried picking from the thumbnail image in the flow.. :)

This seems like it should be so simple, what am I missing??

08-05-2004, 07:52 PM
Good question man, I've really tried the same thing you 're doing and I also get no results. What's really going on? :D

08-05-2004, 11:08 PM
I had the same problem.
Got in touch with DF Tech support.
You should do so, and send a test frame.
In my case it turn out to be that the Z range was very small ( probably depends of the scale of your model ? ), you can solve this problem by adding a custom tool before going into Depth blur, multiplying the Z scale by a factor of 1000.
One good test that I use to see if the Z data is present is the Depth Fog tool that is much more tolerant than Depth Blur.

Hope this help, if it does'nt, contact DF support, they answer very fast and they do know.

Francois Boulene

08-06-2004, 07:58 AM
Ok, I figured out part of my problem. I was saving the files as RLA from either the render options or the image viewer. Once I save them out from the image filter buffer the z picker seems to work, and I get a different values as I move the picker around the image.

Then I had to futz around with it to determine that my focal point needed to be a real small number to give me a facsimile of a small Depth of field.. (0.001)


09-13-2004, 11:49 AM
I'd like a really clear tutorial on this to show what's really going on.

I've rendered out RLA and RPF from Lightwave and man it's just not clear why the Z channel is so tight in range and what the heck you do to tweak and fix it?

09-14-2004, 05:27 AM
I´ve read something related to this on the Pigsfly forum, but unluckily that forum it´s been unavailable for a couple of weeks at least (seems they got problems with the latest hurricane alerts in florida).
Someone at the forum published a plugin that would help to set ok the problems in scale for the Z buffer output from Lightwave, which seemed to be a lot different from what DF would expect.
Ok, i can´t now find where do i have that plugin (i did download but have no yet used nor installed), and can´t reach Pigsfly.
Maybe someone around has it handy.


09-14-2004, 07:32 AM
For Z scaling problem in DF from a RPF or a RLA from LW, use a "custom" tool in your DF flow, before any "depth" tool, with a Z value ranging from 10 to 1000 ( at least this is what is working here, you have to test first ).
I got this from DF support, they are great.

PS. I did upload an image, but it does'nt show on the Preview Post window. I wonder where it went...

09-14-2004, 07:32 AM
ooops, there it is.