PDA

View Full Version : problem with texture mapping



andromeda_girl
07-26-2004, 07:16 PM
hey gang, as i am new to doing 3D work i need some help with a silly simple issue i am having.

i am trying to apply a map with an alpha channel to a model but even though it has an alpha channel, it always comes in with a solid white background.

i have tried several different variations of the map settings and nothing is working.

is there any special trick to this, or special file format LW prefers to use?

thanks

ginhan
07-26-2004, 07:32 PM
It works when I save it in tif uncompressed, 24 format.
I also have an alpha channel, but I don't know if that's the case or that I have the background as white. I haven't experimented enough.
Meaning that when I bring in the tif in LW, the white gets knocked out.

I don't know how to get the tga to have an alpha.
When I try to save it as tga from photoshop, the save with alpha is disabled.

O, i'm using it in the bump channel.

Silkrooster
07-26-2004, 08:45 PM
Try inverting your alpha channel. I think you have it reversed. You cando this in your image editor or in Lightwave, your choice.
As far as TGA goes, I do not have photoshop yet, so I am only guessing at the problem. Check to see if there is more than one variety of tga listed. Such as tga16, tga24, tga32. If you see a number after it. It is stating the bits that will be saved. Whereas 16 bit is high color, 24 is true color and 32 bit is true color with alpha channel. Therefore you would need to save as tga32 in order for an alpha channel to be saved and then you could check or uncheck the alpha channel box in the save dialog.
Just a thought
Silkrooster

andromeda_girl
07-26-2004, 08:58 PM
ok, new to LW, not new to alpha channels :)

i am creating my maps in photoshop, which i think is part of the problem.

i am saving out different file formats in 32 bit format so i get an alpha channel but they are never being recognized in LW, and when they ARE being recognized they are not being utilized, so it is as if they are not even there. the maps always end up being solid images with no transparency in them where they should be transparent.

i also tried creating duplicate files, where one is the colour map and the other is an alpha map but that didn't work either.

really, utterly, totally, completely frustrated and hopelessly lost and confused with this problem.

this is the first time in 6 or 8 years that i have had to do any surfacing so i am relearing it from the ground up.

i have spent the last 10 hours today struggling with this problem and have not had a single sussess yet.

anyone, please help. thanks.

Silkrooster
07-26-2004, 10:56 PM
Check the Image editor and the surface editor's advance tab. Both editor's have a place to disable the alpha channel. Make sure neither one is disabled.

andromeda_girl
07-26-2004, 10:59 PM
ok i see this but the '255' for alpha is greyed out.
i presume this means the alpha is not there.
BUT under alpha i do have it enabled, so it does seem to recognize it is there, so is it or is it not there?
it does not seem to be there, yet it recognizes one yet i have no transparancy
:S

BeeVee
07-27-2004, 05:34 AM
Are you using LightWave 8? In previous versions the OpenGL couldn't display an image map with an alpha, but it looks fine in rendering. As for the second image SilkRooster, that only applies when you render that surface - to which part of the scene it renders, not for incoming alpha maps.

B

ginhan
07-27-2004, 07:56 AM
when you say you saved it in 32 bit, it doesn't automatically have the alpha channel unless you
created one in photoshop.

in photoshop if you look under the channels tab, make sure your created alpha is there,

it should be after the blue channel, (5 channels total)

I'm using version 7 photoshop
save it as a tif, and the alpha channel check box should be checked.

andromeda_girl
07-27-2004, 09:06 PM
ok here it is in a nutshell:

#1: i spent 14 hours + yesterday @#$%^&*ing in both photoshop and LW trying to get ONE single map to work.
i can't say how many times i tried to make a map with an alpha channel that actuctually worked. there were a great many failures.

#2: i know how alphas work, i know how to make alphas. i am a professional compositor who is struggling with a bizarre problem the likes of which i have never experienced before.

#3: every time i bring a file [that was created in photoshop] into lightwave, either it's alpha channel is recognized by LW and it doesn't work anyways, or it's alpha channel is not recognized by LW and it still doesn't work.

#4: i don't know if it is a bug, a problem with photoshop (my guess) or a problem with LW (unlikely) or what it is. all i know is that one of the dead simplest things to do just plain isn't working, period.

#5: a simple, 32 bit image file such as a TGA format image, saved with an alpha channel should just plain work properly: the alpha ensures that the transparent areas are kept invisible, and the solid areas are visible. the issue here is that this simple thing JUST IS NOT WORKING

#6: if anyone has any clue as to why this might be happening, i welcome advice and tipos.

#7: to sum up-
I know how alphas work. i know how to make them. i know how to use them in LW. it just is not working properly.

Elmar Moelzer
07-28-2004, 12:59 AM
Hello!
Please send me the scene and image and I will have a look at it.
It is really hard to tell what is wrong here.
Thanks
CU
Elmar

BeeVee
07-28-2004, 02:14 AM
Again I ask which version of LightWave you are using? It's very important because prior to version 8, Alpha maps weren't shown in OpenGL, leaving your entire image on the surface of your model. However, they rendered out just fine. With version 8, things are simpler, if you have an alpha map embedded in your image and it's enabled in LightWave, you will see your decal in OpenGL...


the downside is that it won't render...

No, just kidding about that last bit, it will render fine! :)

B

andromeda_girl
07-28-2004, 02:22 AM
ok, i thought i did mention it before but i guess i didn't :S

using lw7.5c

and i did do test renders because i was suspicious of open gl errors and they still didn't render properly.

Danner
07-28-2004, 02:26 AM
Alpha channel saving also changed in photoshop a few versions ago, now by default if you delete a zone, it's not transparent as it used to be, now it takes on the background color and it's not transparent even if you save as 32bit. to get around this the simplest way is to duplicate the layer, and erase the bottom one. now your deleted sections will be transparent.

Now in lightwave.
If you map an image onto the color channel, and you have sucessfuly enabled the alpha channel on the image, then you will see the color of the object show through the alpha of your image, that means the object will not be transparent using the alpha as many novice waversrs expect. To have those portions of the image show as transparency you should duplicate the image, and use only it's alpha, then map that into the transparency channel and inverse it. (think of the alpha channel as a black and white image, to lightwave the white portions of the image determine how transparent, thus the inverse)

Hope that helped.

toby
08-01-2004, 01:37 PM
If you can't get it to work imbedded, Clone the image then set the clone to 'alpha only', duplicate the layer in the surface that's using the map, swap the image to the alpha-only one and set that layer to "alpha" instead of normal (it must be directly above the normal/rgb layer).

If you want transparency in the object, put the cloned image in the transparency channel.