PDA

View Full Version : Sliders problem



marvin
03-30-2003, 06:48 PM
Okay, Here is the deal. I'm good with Lightwave, but I'm just learning sliders and came up with a problem. Basically, I modelled a box, went into layout, created a null. On the null, I added the sliders through the object properties. I set the box rotation first, did add, then tried it. Nothing. Same thing with scale and position.

Is there something else I have to set, or turn on? By the way, it's LW 7.5 on a PC.

marvin

hrgiger
03-30-2003, 07:48 PM
I hate to ask this but did you turn on the sliders?

marvin
03-31-2003, 11:39 AM
Did I turn them on? I went to object properties and under the plugin menu chose “sliders.” The slider showed up with the attribute showing that I have turned on. It's just that when I actually slid the bar between 0 and 1 nothing happened.

Is there some other thing you have to do to turn it on, for example shadows on lights. You have to turn on shadows for the light, but also go into render globals and enable ray-tracing before you can actually see any shadows in a render.

marvin

Aegis
04-01-2003, 03:23 AM
Make sure your range is correct - sliders are context sensitive i.e. if your rotation range is 0 -> 1 then the slider wil only rotate your object by 1 degree max - try 0 -> 360

Try this:

1. Clear scene
2. Create a null
3. Add "Sliders" custom object to the null
4. Open the slider panel
5. Add Camera Position.Z
6. Set range Min -5 Max 5
7. Close panel and click on "Sliders" under Items/Tools
8. Move the slider - camera should move in Z axis

hrgiger
04-01-2003, 07:29 AM
That's what I meant, what Aegis said. Make sure you have sliders enabled under the items tool menu on the left.

marvin
04-01-2003, 07:26 PM
It still isn't working!? Okay, this is what I do (to make sure it's not my mistake):

1. Open Layout (yes, it's going to be this "stupid proof.")
2. Add a null and name it "Controller."
3. With Controller selected, open item properties and in the Geometry tab, Add Custom Object, scroll down to "Sliders."
4. Double click on the word sliders that appears in the Add Custom Object area.
5. Choose Camera-->Position.Z from the list and hit Add Channel.
6. Under Range Min, -5; and under Range Max, 5.
7. Close the sliders panel and the object properties panel.
8. Select Sliders from under the Tools menu on the left of layout.
9. When I scroll the slider, NOTHING HAPPENS.

As a side note however, when I go into object properties for the null again, and open the "Sliders" options, the range min and max values say 0, but in the actual slider, it can go from -5 to 5.

Here is the scene if someone wants to take a look at it, but it's zipped. (Again it's LW 7.5 on a PC)

marvin

Aegis
04-02-2003, 03:17 AM
Your scene files works fine - slider moves the camera back and forth on Z no problem - weird eh?

Methinks you need to try clearing out your plugins and adding them again. Failing that I guess blitzing your configs might fix it and if not a re-install of LightWave is on the cards... :confused:

marvin
04-03-2003, 11:23 PM
Thanks Aegis. At least I know I'm not crazy. I could tell it wasn't a difficult plugin to figure out, but it didn't work. I'll try your suggestions, but it is wierd.

marvin