PDA

View Full Version : Trouble with Multi Pass Rendering



marcopolio
03-28-2003, 04:54 PM
I have a very complex render that i am trying to set up as a multi pass render. i render out the different channels using the buffer export plugin. I have rendered my frames to 32 bit .pct files, and 32 psd files. i am rendering them out as images, When I select alpha or rgb I just get either or.. When I render the 32 bit files, i dont get an alpha channel, they are flat images on black. I obviously need them to include their alpha channels. can anyone point me to some tutorials on multi pass rendering, or let me know what I am doing wrong?
-A

Julian Johnson
03-29-2003, 03:28 AM
Hi Marcopolio,

I'm not sure if I can work out exactly what's up, but here's some things you should probably expect:

1. Even if you render out the greyscale buffers in a 32bit format, they won't include an alpha channel. Buffers are normally just 8bit or 16bit greyscale images. I haven't tried it, but I'd imagine the colour RGB and Mirror buffers from the Buffer Export plugin are also without an alpha (or at least a blank white channel).

2. You should definitely get an alpha embedded in the image using the normal RGB save modes with a 32 bit format.

3. The greyscale and RGB buffers are designed to be applied over your base image in an apply mode (overlay, multiply, screen etc.) and can be 'clipped' to the alpha of the image or layer you're adjusting by using either clipping paths/masks or stencil layers. Usually, that wouldn't be necessary because you'd isolate each separate element in your scene (within reason) and render out the individual passes for each layer so that each pass would only be relevant to the layer it referred to.

Julian