View Full Version : LOD Object Replacement Plugin Buggy?

03-27-2003, 11:24 PM
I'm working on a scene at the moment that has rows and rows upon rows of cloned objects.

They will be in a fly-thru type animation starting at one end and finishing at the other - now if the level of detail object replacement plugin would work - this would save me a lot of time and effort setting up the entire scene.

But so far my tests are showing that even when you define a "specific" base object for the plugin (in this case the High rez version)

when you then render a frame and all subsequent objects in the distance are replaced with their low rez counterparts - the plugin for some reason then sets the replacement as the BASE object.

This results in the awkward situation that when you eventually get close to that object during the animation it now thinks the low rez version is the base object and renders that instead of what should be the high rez one for a close up! :(

I've tried to fool the plugin by telling it that anything past 1mm should be rendered as the high res one and then worked from there - but that just brings in even more haphazard results

can someone confirm that this is indeed a problem with this plugin? If it is a bug can it be fixed? And how quickly?!;)

note I'm still using 7.5 and not 7.5B if this is a known bug with 7.5 and it's been rectified for the B pack let me know for sure and I'll upgrade (was putting it off due to 7.5 3rd party plugin dependency)

03-28-2003, 01:57 AM
Yes, there are a lot of bugs in the obj.replacement plugins. I had long talks about it but it seems hard to fix them !!!

But.....have you tried this....


(BTW I don't know if there were fixes on this in 75b. My current projects will last some time, so no "be" for me !!)

03-28-2003, 11:37 AM
Heh - it is a relief to know it's a buggy plug-in and not just me going crazy ;)

thanks for the link - I'll try that later :)