View Full Version : Linux screamernet

03-27-2003, 08:53 PM
Has anyone attempted to set up the linux distribution of screamernet that came with the 7.5b update? I have tried to use it in Slackware 8.1 to no avail.
I got screamernet to run after completing the script file "runsn2.sh" since it naturally didn't contain the paths for the command files. I was able to start the script and immediately saw the standard messages indicating the app was running. I typically see the responses from lwsn in NT4.0 (the "init", "wait", etc) cycle at about half second intervals on my 2 GHz P4. In a half second in linux, about 30 "init" statements appeared. However, I couldn't get LW's network render panel to talk to the app. LW saw the processor was requesting work, but the network render panel never returned to allow selection of a scene after I hit the OK button. I tried again by activating screamernet on my other PCs (a 500 MHz running XP professional and a 833 MHz P3 running NT4.0) and attempted network rendering once again. This time I was rewarded with three screamernet nodes ready to render. I loaded a scene file and started screamernet rendering. Machine 1 (the 833) loaded frame 1, machine 2 (the 500) loaded frame 2, machine 3 (the 2 GHz) tried to load frame 2 multiple times and just tried over and over again. So, I haven't had any success as yet, but I am not ready to give up.

Has anyone else tried screamernet on linux?

03-28-2003, 10:20 AM
I had to give up on it, I don't think the -2 mode works on all if you try to control it with a Mac, it never shows up. And in -3 most of the image savers do not work, and it was having problems with the textures on my objects...

04-02-2003, 04:32 PM
Is anyone from Newtek looking at this thread? I would like to know their response to this. I have been told Newtek checked this out on a Redhat Linux build, but I can't believe that is causing this problem. Did Newtek check it on a network that the file server was running NT 4.0 with an NTFS file structure? That is how my setup is arranged.

:( :( :(

Would someone from Newtek please respond?

Is anyone out there?

04-23-2003, 02:43 PM
I've tried it on debian and it runs, but there is alot of rigging that needs to be done to make it work. I still haven't been able to save a rendered image, but I think that has to do with the type I was trying to save.

I'm glad that NewTek has listened to their users and created the linux binary. Now for a quick tutorial on setting it up.

I'm still working on a configuration that will make it work correctly without redundancy in the system.

Thank you NewTek for the linux package. Completeness would be nice. Coming from a software test engineer standpoint, I would have never let this out the door without a manual.