PDA

View Full Version : Odd problem with morphs



Mipmap
06-07-2004, 07:46 PM
A few months back I'd been wanting to try to move away from the other stuff I'd been doing for so long with LW and try to learn character animating. Very quickly I figured out I'd need to learn how to do smart skinning, and with 7.5 had learned the process of making corrective morphs for joints.

Now, with 8 that same process doesn't seem to be working for me. From what I can tell I'm doing it the exact same way I always did, but my problem is the morphs seem to get scrambled when applied in Layout. Rather than getting an a morph that bends into a nice looking elbow and bulge in the arm, I'm getting something that looks worse rather than better.

Here is what I've been doing:

Layout: Scrub timeline.
Layout: Bend arm X degrees and key arm.
Modeler: Set the elbow skelegon as the center pivot in.
Modeler: Select the whole lower arm up to that bone.
Modeler: Make a new morph.
Modeler: Rotate it the exact same rotation as in layout.
Modeler: Correct the shape.
Modeler: Get the same selection of as before.
Modeler: Rotate it the same amount of degrees back.
Layout: Open Morph Mixer and apply the morph.

From what I can remember what I have done should be correct, but when I open morph mixer for a quick test of the morph I get nothing like what I should get. I remember this same process working in 7.5. Has anything changed in LW8 with the way it handles morphs? :confused:

Mipmap
06-08-2004, 06:59 AM
I made a quick cheap arm to try this out with and experiment, and seem to be having another problem. I make my morph and send it to Layout, but Morph Mixer keeps telling me my object has no morphs. Reloading the scene or even just saving my work, closing both Modeler and Layout to restart them will now help either. I see my morph in the list in Modeler, and when I switch to it I can also see it correctly in Modeler. It just seems to not exist in Layout no matter what I do. :confused:

toby
06-08-2004, 06:58 PM
I've heard this is a new bug; you have to reload the morph mixer plug-in on your model to see any new morphs. They're working on it.

Mipmap
06-08-2004, 07:09 PM
I thought I read that somewhere and had tried it, but deleting and adding the plugin doesn't work. I even deleted the existing morph on the model and created a new one. Then I saved everything with morphmixer removed completely from the object, closed and restarted both programs, and morph mixer still kept telling me the object had no morphs even though in modeler has no problem showing the morph.

Other than that problem, does anyone have any idea about why my corrective morphs don't seem to work? I loaded a model I used the same method on that was done with 7.5 and I could bend bones and apply the morphs to have it correct the shape just fine. But the ones done all in LW8 seem deform strange with some parts seeming to change more than others, and resulting in a slightly crumpled shape. I've tried deleting and redoing the morph several times with no luck, then it was with this separate arm that I did to test with that I ran into the problem of Layout never finding the new morphs. :(

lesterfoster
06-13-2004, 04:48 AM
Originally posted by Mipmap
But the ones done all in LW8 seem deform strange with some parts seeming to change more than others, and resulting in a slightly crumpled shape. :(



Sounds like you have found a bug in modeler(8). Try making your new model in modeler(7.5) and than animate in layout(8). I would like to hear if you have found a bug in modeler(8):confused:

toby
06-13-2004, 03:48 PM
Actually I tried this, and my morphs update like they should - this may just be a problem on your system. Have you tried deleting all the morph plug-ins (from LW, not just the object) and reloading them? Maybe even replace the plug-ins with new ones from the CD?

Ramon
06-17-2004, 04:53 PM
Hello Mipmap ...
I haven't had the problem you have with morphs not showing up in layout...
THOUGH, I have had irritating problems with "corrective" morphs not looking as I shaped them in modeler. I discussed it on CGtalk:
Check out the page and scroll down a bit. You see my post with screen shots.page (http://www.cgtalk.com/showthread.php?threadid=96005&perpage=15&pagenumber=4)
In short I believe it has to do with something fnky going on with 8's pitch and heading channels getting screwy. (I'm not 100% on that though and I'd like to hear other ideas on this also).
Good luck. This problem ticked (rather, is ticking) me off a good bit. By the way you can fix one by rotating the bank (so that the heading is now your elobows rotational axis - use the bone twist tool on the shoulder bone to affect the elbow bone). This method will work for one morph BUT, if you try to tie in an addition morph with it - you'll get FUNKY TOWN!