PDA

View Full Version : AAAAGHH - Uncrontrollable Camera!!



kevinmcpoland
05-30-2004, 09:35 AM
Okay, if I had hair....

I have never really managed to figure this, but IT IS A PAIN!!!

I have a simple camera animation I wish to do.

Scene: A Poly with a map on it. A Car object rotating on the map.

The wished for outcome: I want the camera to be static at a low angle on the car for about 125 frames, then gradually pull out and up to show an aerial view og the whole map.

The Problem: Whenever I pull the camera out and back, I get ANNOYING movement on the camera, e.g. If moves forward first then back in my supposedly static 125 frames. I don't want this!

Tried solutions: I have tried targeting the camera at a null and moving that at the same time, no use. I have tried fiddling with the bias settings etc in the Graph editor, from linear to bezier, still no use. I always seem to get this camera movement first.

When looked at in various angles I can see the camera motion path curved slightly, again why can't it just do what I want....?

Thanks anyone...?

Kevin McPoland
[email protected]

bloontz
05-30-2004, 09:48 AM
Sounds like you need to set the splines for the static frames to linear in the graph editor, if I understand you correctly. Other spline types will have that problem as they don't end abruptly at a keyframe.

Ztreem
05-30-2004, 09:57 AM
Set all your points in the graph editor to linear.

You can also set the curve type in graph editor prefs, so it always do linear curves. Then you always get what you want. :cool:

dwburman
05-30-2004, 01:28 PM
In the graph editor:

Set the tension at 1.0. That way you get an ease-out but not the movement at the beginning.

Or delete the keyframe at 0 so that the first keyframe is the one at the start of the move.

LW is trying to smooth out the motion across the keyframes. Doing one of those two things always fixed it for me.