PDA

View Full Version : Artifact in Atmosphere



drfoley
05-25-2004, 08:23 PM
Hey Guys,

Anyone know what might be causing this awful silhouette around my asteroids?

How would you fix this?

Thanx
DrFoley

drfoley
05-25-2004, 09:08 PM
BTW, it doesnt appear that Light Intensity has anything to do with it. I turned that down and it still shows the artifact.

Thanks

emperorchuck
05-26-2004, 12:32 PM
How are you doing this? Because it looks to me like you're adding the atmosphere as a post effect. Try compositing- do the planet, then composite the asteroids on it without the glow settings... That's the best I can offer without knowing how you approached this.

drfoley
05-28-2004, 09:44 AM
Well...first of all I have to thank Fabio for creating the planet. I'm just using it in my scene.

It has Glow applied to the Atmosphere surface. Is Glow a post-effect? Anyway, I think your right about having to composite it but I dont know how to do that.

Can you composite in Lightwave or do I need to do all of that in Premiere?

I'm sure it is the Glow that is drowning out the borders of the asteroids now because its fine with Glow turned off. Its just that the Glow makes the planet look so realistic.

Question: Can I substitute a different arrangement of lights or Luxigons for Glow and still have a photorealistic image without having to composite anything?

Thanks,
DrFoley

emperorchuck
05-28-2004, 01:59 PM
Well, yeah, glow is a post effect. While you could try poking around with lights or luxigons for glow, it won't have the same effect and could quite easily be a huge headache. Compositing is much simpler in this case.

What you do is this: Render your scene, minus the asteroids. Dissolve them, make them unseen by the camera, or just cut them. Doesn't matter much. This render has glow enabled, and is your background shot.

Once you have the render with the planets and glow (very nicely composed, btw) you set up the scene for the asteroids. Keep all of your lighting settings the same, but have no objects aside from the asteroids. Set your planet render as the background image, and disable glow (you won't need it for the asteroids, but it'd be fine either way). It is rather important that your settings stay the same, as this guarantees that your image will fit (I hate seeing crappy composites with lighting that doesn't match, the wrong filters, etc. Of course, it ain't easy if you didn't make the first image. But that's an aside) Now, render your scene. Hopefully, that'll eliminate your glow problem.

This method should work for animating, too. Just be certain that when you make your background video, it has equal or greater pixel dimensions than your desired end product (So it looks pretty) and save it as full, uncompressed frames. Otherwise, it's essentially the same stuff.

drfoley
05-28-2004, 02:54 PM
Hey thanks for your tips.

I'll give that a go.

You said make sure "it has equal or greater pixel dimensions than your desired end product. " I'm sorry but what are "pixel dimensions"? Is that your resolution or aspect ratio?

DrFoley

emperorchuck
05-28-2004, 03:35 PM
Sorry... I mean the resolution. For best results, if you want a 2000x3000 render, the background should be at least that.