PDA

View Full Version : Those Damn Triangles



John Kelly
05-14-2004, 04:10 PM
I am the first to admit that I am no spline modeling pro. and would love some help figuring out why I get these triangles when I render.
This is a subpatch nose I just made. There is no ambient light, so the nostrils should be completely black. The polygon statistics in modeler say there are no non-planer polys...
Increasing the geometry just makes the triangles smaller. What am I doing wrong?

Thanks in advance for any assistance.
jk

Silkrooster
05-14-2004, 08:19 PM
I modeler press o for general options and look at the polygons drop down button. See if it is on automatic, triangles, or quadrangles. Try changing this to quadrangles before modeling, that should take care of it.

John Kelly
05-14-2004, 09:23 PM
Modeler is set to quads already.
The model is totally sub-patch quads. It is my understanding that the triangles are generated in layout for rendering. What has me stumped is why I can see them??? I don't want to see them, thats for sure!

Thanks,
jk

SplineGod
05-14-2004, 09:44 PM
It looks like shadow map errors.
Try upping your shadow map size, reducing the cone angle on your spot light or both. Also try reducing the fuzziness.

John Kelly
05-14-2004, 10:08 PM
That was my first thought too. So just to be sure,
I did another test. I lowered the fuzzyness to 1 for the lights, and upped the map size to 5000. I checked to make sure the beam was tight too.

The result is less than perfect but somewhat better. The increased shadow detail is a hog on the processor speed though. And there are still some signs of errors. It looks like I've got gaps. I can't imagine how that light is appearing in the nostrils, and I can still see some evidence of the geometry in the render. I can't help but feel that I am missing something else.

Thanks,
jk

SplineGod
05-14-2004, 10:18 PM
Try changing the subpatch order to last. How many lights do you have and how many are using shadowmaps?
You still may need to use larger shadow map. That still looks like shadow map errors.

John Kelly
05-15-2004, 03:30 AM
I guess I thought the problem was more complicated. After tweaking awhile, I managed to eliminate the render errors with bigger and better shadow maps. Thanks SplineGod! It is a shame to loose those wide soft shadows though, but I guess that's what radioscity is for.


To answer your question though: There are three lights. Key, fill, and back, all spots with shadow maps.

thanks,
jk

SplineGod
05-15-2004, 03:34 AM
I use shadow maps all the time and get nice soft shadow edges.
You can also use areas lights or the spinning light trick.
Whats the scale of your object? Is it pretty big? Try sizing it down and see what happens. :)

John Kelly
05-15-2004, 05:15 PM
The whole head is about .3 meters. Not too big. Does the scale of the scene change the shadow quality?
jk

SplineGod
05-15-2004, 06:13 PM
I know that the scale of the scene can affect other things like IK and Ive seen it even affect textures. If youre scene is a very large scale try reducing it. If youre character is also very far from the origin that is the same as a large scale scene. Move everything as close to the origin as you can. :)

Aegis
05-15-2004, 06:47 PM
Also, move your spots closer and tighten the cone angle - this makes a huge difference...

Elmar Moelzer
05-15-2004, 07:11 PM
Or use Area lights with raytraced shadows, looks better too, but may render a bit longer (depeding on the size of your shadowmap, it is my personal experience, that the difference can be almost neclegtable).
CU
Elmar

John Kelly
05-16-2004, 02:20 PM
Wow, thanks for all the responses. I've been trying out all of them in various combinations.
I must have the scale right, because it doesn't seem to be a factor when I adjust it up or down dramaticly. The object is at origin, so no issue there.

I am posting my results in case there are any newbies like me who would benifit from my experiment. I've learned a lot and really appreciat e all the help.

Thanks,
jk

John Kelly
05-16-2004, 02:23 PM
this one is raytraced spotlights. the image clocked in at 3.9 seconds. Very clean, really. I've figured out that the light in the nostril is due to the fact that I don't have the entire head done yet. So light is coming in from the back. So just ignore that for now.

John Kelly
05-16-2004, 02:25 PM
This one is with all shadow mapped spots. They are set to 5000 map size and fuzzyness of 2.
very similar to the raytraced image, except that this one clocked in at 6.3 seconds. Notice the render errors showing up. These will go away, mostly with increased map size.

John Kelly
05-16-2004, 02:29 PM
I set the fill and back lights to raytrace, and then adjusted the key light's fuzzyness to 13.5 to try and reclaim some of the softness of the original image. This one took 5 seconds. The render errors were much worse. At this point I realized that the shadow mapping is always going to have this problem, it is just a matter of upping the map size and backing away. The issue is getting a soft light without heavy render times.

John Kelly
05-16-2004, 02:32 PM
next I converted the lights to area lights. I wasn't able to make them shadow mapped as well--the option was ghosted. This worked very well. I can still faintly see the render errors, but we are very close in this view as well. This image took 44 seconds to render so there is obviously a price to be paid.

John Kelly
05-16-2004, 02:35 PM
And lastly I thought I'd try radiosity just for comparison. The lights were set to ray trace and the radiosity is out of the box. It took 1 minute and 52 seconds to render. Clearly this technique in concert with the others would give the best results. All the softness with hard shadows too! But for the money, the area lights seem to be the best compromise. Thanks again everybody.
jk

iandavis
06-02-2004, 10:18 PM
umm... there are a lot of things in Lightwave that SHOULD work but simply dont, like supershift. I have had nothing but RENDER ERROR CITY trusting layout to triple polygons. So for final renders freeze and triple. Your weirdness should vanish.

I have a whole folder full of your kind of rendering nonsense until I realized the above.

cheers

iandavis.ws