PDA

View Full Version : LW icon help



mechis
05-06-2004, 04:54 PM
Hi all,
I installed LW8 and for some reason, my .lwo files do not show the lightwave icon. .lwo files are associated with modeller, but the icon doesn't show.

Can anyone help?
~Mechis

tokyo drifter
05-06-2004, 05:21 PM
I have the same problem. I only have icons on .lws files, for some reason .lwo files don't have an lightwave icon, just the default windows icon.

bloontz
05-06-2004, 05:31 PM
Mine have icons (win xp), I think file icons are set in the registry in windows. If they aren't showing up there is probably a small problem with your registry. Try reseting the file association or using a file association editor.

Gregor
05-06-2004, 05:37 PM
My quick link bar for awhile kept forgetting that I changed to the new Modeler icon, and was periodically reverting to the old one (I suppose I could've created a totally new shortcut, but I was lazy.)

Seems to have finally "taken", but we'll see.

The problem with no icons on objects is because modeler isn't getting registered as the default app for objects. Instead, it says "Unknown Application".

You can fix that by going into the prefs for any random object and clicking "Change" (on Win2k, at least).

mechis
05-06-2004, 05:40 PM
Hey,
I was making a screenshot for people at another forum and somehow my problem fixed itself. The icons magically appeared. I don't know what I did to fix it. Computers are a mystery to me...
~Mechis

riki
05-06-2004, 06:42 PM
I haven't seen a LWO or LWS icon on my system for ages. What's more annoying is when I double click on a LWO file and it launches my demo of Bodypaint or even worse DivX.

Yeah I know I can change it for all objects, but it invariably happens again a few days later.

Silkrooster
05-06-2004, 07:40 PM
I checked mine, and your right. From what I can figure is when both versions are installed, the association gets lost. I reassociated the icon to LW in the LW8 folder and the icon is now there. However LW7.5c loads. So I am going to do some research to see why.

Signal to Noise
05-06-2004, 07:59 PM
Hey mechis. I PM'd you through...ahem...CGTalk. Looks like you got your icons fixed anyway.

I didn't even know you could have unique LW icons for the files. I've always just had the "mystery icon" Windoze likes to slap on stuff.:)

mechis
05-06-2004, 08:16 PM
Hey Signal,
Yeah. Thanks for responding to my pms. heh. Sometimes I get annoyed and won't stop messing with my comp till it's working the way I want it to.

Oh, and for anyone else with this problem, here's one method that Slayer pointed out to me (it's not what I did though- I don't know how I fixed mine, but I figure this could help some people out)

http://vbulletin.newtek.com/showthread.php?threadid=22080

~Mechis

Silkrooster
05-06-2004, 08:42 PM
If your not comfortable with editing reg files then please find some one else that is comfortable. Make sure you back this file before preceeding as it is possible to corrupt the registry and have to reinstall windows if you make an error.
Ok, I was able to correct it. For those that are familar with regedit for windows XP. I will tell you how to do it. Download the LW8patch zip file. Enclosed are two registry files one for modeler and one for layout. Extract these files to someplace you can find. Start regedit to do that click on the start button, select run..., type in regedit, and select ok. Now before you go any further, make sure you back up your registry. To do that goto file on the menu, then select export, give a name like backupmonthdayyear, then at bottom of window make sure you select all for the export range.
Now that you have the registry backedup. Select file from the menu and then select import. Now you will locate the patch file you downloaded. Select either the layout or modeler file that you need. If the other program is working just fine, then don't worry about it. Once you select select ok, you can verify that the patch worked ok, by selecting the + by the HKEY_CLASSES_ROOT to expand the list. Now scroll down until you see layFile or modFile and expand which ever you had imported. Look at the Open command default value. Here it should show the location that the modeler or layout would be installed for Newtek's default location in the program files folder. If you had changed that location when installing LW8 then go head and change the value here.
Once you verify that everything is OK, go ahead and close regedit.
Now Open explorer and find a lwo file. Right click and select Open with..., then select choose program. Make sure you select the correct modeler or layout as there should now be two listed. The icons are as follows. Cyan for Lightwave 7.5 and purple for Lightwave 8. Make sure you select the box below to make this the default program for loading.
Once you select OK, you should be ready to go. By the way in the zip file are 600x800 screen grabs to kinda help out if you get stuck.