PDA

View Full Version : Viewport Navigation is... crap?



Buuu
03-22-2003, 10:06 AM
Hi,

(1) serious problem:
I thought, Alt + lmb is supposed to rotate my view in the perspective viewport in modeler. Well it does, but somehow the whole szene is turning arround and is upside down when moving the mouse left/right. How is one supposed to model that way?? I get a really weired rotation. The rotate button in the viewport works though... (2) btw, how can I change my action center when i rotate my view?

(3) Ok last question =)
Please, tell me that is it possible to change the Viewport Navigation Controls in Lightwave (Layout & Modeler). I HATE IT having to press three buttons to move and zoom. Maybe something like this: Alt + lmb -> Rotate, Alt + mmb -> Move, Alt + rmb -> zoom. Pleeeeaaassseee!! That must be possible somehow.

Skonk
03-22-2003, 11:44 AM
There are navigation controls on the top of each viewport, personally i vary rarely use the key + mouse controls to navigate the views, i use the cursor keys to move left/right/up/down and <> to zoom in/out in the wire views and when rotating i use the rotate button at the top of the perspective view. The only time i ever use the alt + rmb to roate is when my perspectve view gets locked (sometimes happens if u look directly up or down).

James..

Buuu
03-22-2003, 03:42 PM
Thanks for the reply.

I find it very strange that nobody else has a problem with this. easy accessable and intuitive hotkeys for camera/mouse interaction while modeling is a essential thing imho... Don't you think so?? Since dragging the cursor of the object to do basic movements every two seconds really wastes time. :(

Does somebody have an answer to 2?

faulknermano
03-22-2003, 06:24 PM
Originally posted by Buuu
Hi,

(1) serious problem:
I thought, Alt + lmb is supposed to rotate my view in the perspective viewport in modeler. Well it does, but somehow the whole szene is turning arround and is upside down when moving the mouse left/right. How is one supposed to model that way?? I get a really weired rotation. The rotate button in the viewport works though... (2) btw, how can I change my action center when i rotate my view?

to # 1: it really depends on where your cursor is when you are rotating. i prefer modeler's navigation this way: it allows me to get really into the model, into very narrow gaps, as long you know how to position yourself using the mouse cursors. hopefully it will become famililar to you.

to # 2: you can, like many other apps, simple press shift + A to center on a _selection_. that will give you starting place to manuever further.

hrgiger
03-23-2003, 10:49 AM
I don't know if this is the same problem you're talking about but once in a while when using the navigation rotate button my model will get 'stuck' in a way and it will no longer rotate around 3 axises and it seems to only rotate around the Y axis. It really annoyed me for a while. I finally realized that if I hold down shift(or ctrl maybe?) while I drag that the full axis rotation is restored.

Buuu
03-23-2003, 11:30 AM
No it's not the same problem. Ive found out that navigation with alt key is easier to control if you drag only little distances.

But now I have another question: Why don't I have a magic bevel tool under my normal bevel tool? (7.5b)

hrgiger
03-23-2003, 05:34 PM
Under your normal bevel? Magic bevel is a totally seperate plug-in and mine is under additional under the construct tab.

Buuu
03-24-2003, 04:01 AM
Oh I see. thank you.