View Full Version : SkyTracer2 broken/bug?

05-04-2004, 05:33 PM
When I use Sky Tracer 2 it seems to not work when using the default image saver (Deluxe .rla)

Start with an empty scene.

Open background options and add Skytracer2 to the environment.

Now double click on the skytracer2 and just click sky baker

When it is done it will ask you if you want to add it to the current scene and select yes.

Now if you look around in layout it appears that it is working fine you see the default generated sky. But when you press F9 to do a preview render, you get nothing but a solid light blue picture.

I think the Lightwave renderer is ignoring the .rla file. If you check the LW_sky object in the surface editor, click on the texture button you see that the image shows up there, but in the surface editor preview sphere it is just plain blue.

Now if you do the exact same steps above but instead of using the Deluxe RLA saver use the TGA24 saver, everything works normally. But you have to manually pick the generated TGA files because skytracer automatically tries to load .RLA files. If you left the old .RLA files in there Skytracer loads them instead and you'll get the light blue picture when you press F9. But if you replace all the .RLA files with the .TGA files in the image Editor you get the proper results.

Another bug with Skytracer2 is that the LW_Sky.lws it gives the following error when you try to load it into layout:

Line 32, stack empty, no value to assign to variable ::LoadSceneFPS

05-04-2004, 08:48 PM
Check to see if you have the alpha channel disabled. If there is alpha information available and it is not disabled your not going to see the sky. That is why you can see the sky saving to some formats and not others, because some formats do not support alphas.

05-04-2004, 10:56 PM
You mean in the image editor source panel right? If that is the one then yes the Alpha chanel is enabled for all the images, unless there is another alpha channel enable that I do not know about.

Edit: Tried PNG32 and it gave the same result but when I went into the image editor and set the Alpha channel to disabled the sky was present. I went back and tried the DeluxeRLA again and I had to disable the Alpha for it to show up.