PDA

View Full Version : Newtek Customer Support Response Time



ghopper
04-10-2004, 12:50 PM
On the 6th of this months I registered my copy of LW7.5 ( LW8 / DFX+ upgrade ) online, in order to receive the LW8 upgrade. First of all I didn't know that I had to register again to receive my upgrade, I'm already a LW6.5 registered user.

Anyway, after 2 days not receiving any emails from NT at all I emailed them asking for my registration status. Well, no reply either, so I called them on Friday, but I guess they were closed.

On the same day ( 6th ) I submitted a customer service request to Macromedia, and guess what, I've received a reply within 6 hours.

So, is NT's customer support always this slow in responding, or am I just being too impatient ?

I just want to get my LW8 upgrade in time when it's being released later this April.

TyVole
04-10-2004, 01:15 PM
I've found both customer and technical support to be extremely slow by e-mail.

Call them first thing Monday morning. I believe they open 10 A.M. CST.

jevinstudios
04-10-2004, 02:00 PM
I've never used email to contact NewTek -- I always call (of course, if you live outside the U.S., this isn't always as convenient). I've found them to be EXTREMELY helpful and professional every time I've called (especially Richard in Customer Service). Call 'em on Monday, and I'm sure you won't be disappointed.

ghopper
04-10-2004, 05:51 PM
For me emailing is more convenient, and I just wanted to know what NT's response time was. I'll give them another call on Monday.

thx

Jockomo
04-10-2004, 07:26 PM
Email response time = days or weeks

Phone response time = a few minutes


IMO they should make an autoresponder for email that says, we do not offer support via email. Please call us at the following number.


Actually I believe the first support option should be the forums, that way they build a user accessable database of support. At least Kurtus (in addition to BeeVee) has been posting there lately, which is a huge improvement. But I would still prefer that they put all of their focus there. IMO if you knew you could get fast and free answers there, they could begin to charge for one on one support.

mkiii
04-10-2004, 08:05 PM
Odd. Newtek Europe usually respond the same day.

riki
04-10-2004, 09:33 PM
I've sent off tech support question via email before and had no-reply, which leave me less than impressed with customer service at Newtek.

They should think about adding a tracking system, with an automated reply and tracking number/ time-stamp, some way of varifying that a querie is being processed.

hazmat777
04-11-2004, 12:30 AM
If you can call them, do so. The person your trying to reach (sales, service, whomever) is almost instantly available. At least that has been my experience...I was very impressed that I actually had a person to talk to instead of having to go back and forth with e-mail.

jamesl
04-11-2004, 12:59 AM
I've made my share of negative comments about Newtek, but the one place where they SHINE is customer service. Try sending an email to Alias/Wavefront. Unless you have a few dozen seats of Maya installed, I doubt they'll turn around a support call quicker. Call Newtek's support number, and you'll get your problem solved.

j

riki
04-11-2004, 02:58 AM
I sent a tech support question off about 3 months ago. I included my registration details, product details, system details and serial number. I resent the message about a week later , but nothing, I'm still waiting for a reply.

Alias wouldn't have to work hard to do better that that. Plus it's not the first time that my tech support questions have gone ignored.

Sales support is not much better.

hazmat777
04-11-2004, 03:02 AM
Is it worth another 4,000 dollars?

hazmat777
04-11-2004, 03:08 AM
Also, if you're having a problem with Lightwave why don't you try sending the issue to the community? That's the point isn't it? We can help each other faster than a company that is trying to troubleshoot new versions.

hazmat777
04-11-2004, 03:14 AM
Not trying to be irritating here but, why are you still listed as a "newbie member" if you have over 2,000 posts?

riki
04-11-2004, 03:26 AM
I always post tech problems in the Newtek Forums. But that's not really the issue. Tech support questions should be answerred not ignored.

The price is also not the issue. I have a web hosting account with a company based in Dallas, which I only pay $9.95 per month for, yet they're able to handle tech support queries in less than 24hrs

jamesl
04-11-2004, 03:33 AM
Originally posted by riki

Alias wouldn't have to work hard to do better that that.

And yet, they don't.

j

hazmat777
04-11-2004, 03:36 AM
Unless I am very dense, it seems you still haven't explained the exact problem that you were trying to get solved in the first place. Maybe I'm dumb, sorry. I'm new.

hazmat777
04-11-2004, 03:57 AM
If Newtek can't answer it, ask us... What is it your trying to do?

Jure
04-11-2004, 05:26 AM
... in my case I haven't gotten any response from Newtek at all. (Was trying to reach them about some shipping troubles and also info about edu. versions). I've sent emails to [email protected], Ben Vost, PM'ed Ben Vost, sent email to Chuck but no answer from any of them... It's been more than a month since my first e-mail... :(

OTOH my local resseler was very prompt in response. But unfortunately they weren't able to help me with that specific thing. :(

IMO any response would be better than none at all... or a tracking system like riki suggested.

cheeers,

riki
04-11-2004, 05:52 AM
Unless I am very dense, it seems you still haven't explained the exact problem that you were trying to get solved in the first place.

The problem I was having has been sorted, I worked it out myself.

But the more pressing issue remains, the poor response from Tech Support.

Original1
04-11-2004, 09:17 AM
Originally posted by Jure
... in my case I haven't gotten any response from Newtek at all. (Was trying to reach them about some shipping troubles and also info about edu. versions). I've sent emails to [email protected], Ben Vost, PM'ed Ben Vost, sent email to Chuck but no answer from any of them... It's been more than a month since my first e-mail... :(

OTOH my local resseler was very prompt in response. But unfortunately they weren't able to help me with that specific thing. :(

IMO any response would be better than none at all... or a tracking system like riki suggested.

cheeers,

Thats strange I normally get a responce on any kind of Technical Issue same day.

Sometimes sales related issues take longer, but I do get a responce.

Original1
04-11-2004, 09:19 AM
Originally posted by Original1
Thats strange I normally get a responce on any kind of Technical Issue same day.

Sometimes sales related issues take longer, but I do get a responce.

I usually post tech stuff here as well if Its after hours in europe, since somebody on the boards may have had the same problem

hrgiger
04-11-2004, 09:28 AM
I've always had good response from Newtek but then I usually call. I only emailed them once and that was when I registered Lightwave and I got the response back the same day.

Chuck
04-11-2004, 11:29 AM
Originally posted by Jure
... in my case I haven't gotten any response from Newtek at all. (Was trying to reach them about some shipping troubles and also info about edu. versions). I've sent emails to [email protected], Ben Vost, PM'ed Ben Vost, sent email to Chuck but no answer from any of them... It's been more than a month since my first e-mail... :(

OTOH my local resseler was very prompt in response. But unfortunately they weren't able to help me with that specific thing. :(

IMO any response would be better than none at all... or a tracking system like riki suggested.

cheeers,

If your email address is the same as you used for your forum sign-up, then your email never reached me. I've reviewed my mail box and find no message from that address. Please try again, or try Ben Vost, since you are a European customer. I can assure you, if we or they receive an email, we respond.

Kurt_Henning
04-11-2004, 11:59 AM
I have used Newtek Tech support since 1993. They have gone beyond the call of duty to assist me. With Newtek, I have found that they actually try to solve my problem, instead of the normal tech support line about blaming MY hardware or the OTHER APPS on my system.

Not only is tech support still free of charge, it is still way above the norm.

We were forced to pay for Media 100 tech support, and they gave up on fixing our problem, and we ended up selling the $35K systems for $11K and the new user could not use the remaining 7 months of the tech support that we paid for.

So, newtek is very unique, a dedicated bunch of people who want their users to find success.

You can complain on the forums, but as stated in the post above, Chuck Baker has helped thousands (conservatively) of users solve their problems. And I bet he can find the resources to fix yours.

And, if he does not have an e-mail from you, then how could he solve your issue?

I suggest resending the e-mail.

Try that.

Or, you can take the position that they do not care about users, and you would be mistaken.

Best of luck to you.

hairy_llama
04-11-2004, 12:20 PM
Some email accounts have problems sending and others recieving.
I had my wesite hosted by someone and also me email. After months I found out that I was not receiving a LARGE amount of the email sent to me and the sender would not even get a "mail undeliverable" msg.
I've also heard that a lot of ppl have problems with aol email not recieving.
I wonder if that could be a problem in this case?

Jure
04-11-2004, 12:40 PM
Thank you for your reply Chuck, I just sent out my email again explaining my problem. I sent the email to [email protected] with a CC to [email protected] just in case...

It did seem very weird to me that no one was responding since I heard Newtek had great tech support. I also didn't want to continiously send out emails since I wasn't sure anyone was receiving and I figured maybe you guys are just so busy with [8] and didn't have time to respond or something...

It is weird you haven't received email since I haven't had problems sending or receiving emails in years.
Please report if you don't receive my email again.

Thank you again for your prompt response.

cheers!

Original1
04-11-2004, 12:41 PM
Originally posted by Chuck
If your email address is the same as you used for your forum sign-up, then your email never reached me. I've reviewed my mail box and find no message from that address. Please try again, or try Ben Vost, since you are a European customer. I can assure you, if we or they receive an email, we respond.

There you go how often do you get a response from the senior director of corporate communication on an Easter Weekend?:cool:

hey Jure,

Nice avatar by the way

Jure
04-11-2004, 12:47 PM
Yes Original1 I agree, great to see such a fast response. I just hope they get my email this time.

BTW - there's more about my avatar here if you are interested:
http://www2.arnes.si/~ssdjjude/

riki
04-11-2004, 06:48 PM
I sent a sales support question on the 26th of February regarding the upgrade special. I didn't get a response until 5 days later on the 2nd March, and that was only after sending a second email chasing it up.

CB_3D
04-11-2004, 08:06 PM
NT Europe works well, usually a day or two to get a response.

Chuck
04-11-2004, 10:31 PM
Originally posted by Jure
Yes Original1 I agree, great to see such a fast response. I just hope they get my email this time.

BTW - there's more about my avatar here if you are interested:
http://www2.arnes.si/~ssdjjude/

Got it, but I think I see why it might not have gotten through here or at NTE previously - instead of your sending address showing up as your name and your email address, your name was embedded in a string - "=?iso-8859-2?Q?=22=D7_Jure_J._=D7=22?= " - and our filters often look for those kinds of strings to reject email as being generated from a spambot. I did a reply and edited out the string characters to leave your name, and cc'd Ben so he'll get my reply even if your message didn't get through their filters, and can follow up with you. I'm sure they'll get you taken care of.

Jure
04-12-2004, 03:29 AM
Thanks Chuck you're great!

Will look at that string thing and try to fix it!

cheers!

BeeVee
04-12-2004, 06:42 AM
That must be it since I don't recall seeing an email from you Jure. It's sometimes frustrating on the forums that we can't get more info about the people on the forums since it would help to pinpoint problems, if you see what I mean... :) Obviously, I'm not at work either today, so I can't look through my emails to see if there's one from you that slipped through the net...

B

Jure
04-12-2004, 03:32 PM
Thanks Ben! I look forward hearing from you!

cheers!