PDA

View Full Version : ...help with pfx file that wont load...



Boo!
04-07-2004, 05:09 AM
...me again
im workin from a DVD tutorial(desktopimages) which shows you how to make liquid mercury pour onto collision blocks and pour off them. now theres a project file which contains this:

Mercury.pfx

first off, Layout gives me a message sayin that it cant load it, then i click 'ok' and then it proceeds to open the file for me to work on.
now every time i go to render the animation just before it finishes renderin the first frame it gives me a message readin:

Plug-in image saver failed. Abort rendering?

if i continue i get the animation minus the liquid mercury pourin down and off the collision blocks that have been set out, which is the whole point to the tutorial.

i thought id ask you guys first before headin to Desktopimages cause their kinda of slow in replyin.
any help here please?...
:confused:

mlinde
04-07-2004, 07:49 AM
Is this with a sample scene? If so, open the scene file (*.lws) in a text editor and look for the path of the Mercury.pfx file. I'll bet money it's got a fixed windows path (C:\Content\Sample\Mercury.pfx). If it does, open the scene (in Layout), go to the ParticleFX window, re-load the saved settings (it's in the last tab of the FX options), then re-save the scene. That should do it.

Boo!
04-07-2004, 08:55 AM
...thanks for the reply dude
...
Plugin CustomObjHandler 1 FX_Emitter

format 1

s0 0.5 0.01 0.5

p0 0 0 0 1812 300

v0 0 0 0 1 1 0

g0 0 -2 0 1 Scenes\Projects\Mercury.pfx

b0 0 300 1 1 1 250 0 0 1 0 0 0 0 0 2 1 1 0 1

ve 2 1 0 0 0 0 0 0.02 0 0 1 0 1.5 1.5 0.1

EndPlugin

ShadowOptions 7

...is this what you mean?...
the only other is this that comes close to what you mentioned...

SaveRGBImagesPrefix C:\Production\Training\Tapes\Basic HV\OutPut\Mercury\HV3_Liquid_A.

RGBImageSaver LW_TGA32(.tga)

SaveAlpha 0

:confused:

toby
04-07-2004, 12:19 PM
What mlinde is saying is to go to the emitter panel, last tab, hit 'load motion' and browse for the 'Mercury.pfx' file. Once you load it I would save it again ('save motion') onto your hard drive, then save the scene as a new scene.

As far as the plug-in image saver error, that's a separate problem. Delete your i/o plug-ins (this does not erase them) and reload them.

mlinde
04-07-2004, 01:50 PM
This:

Originally posted by Boo!
Scenes\Projects\Mercury.pfx
and this

SaveRGBImagesPrefix C:\Production\Training\Tapes\Basic HV\OutPut\Mercury\HV3_Liquid_A. are the problems I mention. These files are paths for Windows PC locations. The Mercury.pfx file (if it was a proper path) would look like this:
Scenes/Projects/Mercury.pfx
The forward slash is the platform independent structure used in the newer parts of Lightwave. Unfortunately, using the forward slash will not work with PFX, because when you do reload/resave, it will look like this:
Scenes:Projects:Mercury.pfx
Which is also wrong, according to the newer pathing principles in Lightwave. Make sense?

Boo!
04-07-2004, 02:05 PM
...thanks guys:D
im on the jazz right now!
the first part worked that Toby was talkin about just tryin the re-placin of i/o plugins.

i'll let you know the out come as soon as.
again THANKS! to both of you. i really need this for this job im on.
:D

Boo!
04-07-2004, 04:43 PM
...thanks its workin!:D :p :D

toby
04-07-2004, 10:28 PM
we take kick-backs :)