PDA

View Full Version : Using Alpha channels in Layout



dranos
04-01-2004, 10:00 PM
I have a simple polygon and I want to use an animation of a waterfall as the texture without seeing the polygon. I've rendered out the waterfall animation as animation + alpha so that I only see the water but the problem is that the polygon keeps rendering along with the water. I know this has something to do with a clip map and I've tried but I can't get the texture to render without the polygon. What is the correct way to do this?

Beamtracer
04-01-2004, 11:22 PM
I usually render a separate matte shape as a different image sequence or Quicktime. Think of it as an alpha channel on its own without the color RGB information.

You can use it as a clip map in the Object Properties panel, or alternately use it as a transparency channel in the Surface Editor. Transparency can sometimes look better, but takes longer to render.

dranos
04-02-2004, 07:20 AM
I had an idea that it involved that but unfortunately the waterfall animation was created with hypervoxels and I can't to render it out as a matte object. Is there any other way to render this waterfall movie on a polygon without seeing the polygon?

eblu
04-02-2004, 07:33 AM
dranos,
put up an image?

I suspect it might be a specularity issue, but for the life of me, I can't make sense out of what you wrote... so... a picture is worth a thousand words

mlinde
04-02-2004, 07:47 AM
Without seeing it, what happens when you check "Unseen by camera" on the polygon?

dranos
04-02-2004, 09:49 AM
Here is a picture of the file I'm working with. The green is the background don't mind that. The grey object is the polygon I don't want to render. The orange liquid is flowing and so I need it to look as if its the only thing there. You're probably wondering why I didn't just render hypervoxels on an alpha channel, well I need a ton load of these 'slim falls' in a scene and getting them to be textures saves time not to metion that Lightwave crashed when I tried that route.

eblu
04-02-2004, 10:04 AM
i have duplicated this problem.
and gotten advice from my own in-house LW guru.

here are the steps to Fix the problem.

1. open the image editor (look near surface editor)
2. select your texturemap in the left
3. clone it (button in the top right of the window)
4. select the clone
5. set the clone to be "alpha only" under the alpha channel

6. go to your clip map
7. change the image to your cloned version of the image.
8. invert the image
9. turn off antialiasing, and pixel blending

the clip map was using your color map as its transparency value, and it was normalising the image, making nothing clipped. what we did in the above steps, was to tell the clip map to use our alpha which in turn gave the clip map enough contrast along the edge to properly clip out the polygons.

dranos
04-02-2004, 10:25 AM
I got a blank screen after rendering. Here is what I did. The name of my tex is juice. When I uncheck 'invert layer' I get the image I posted before and when I check 'invert layer' I get a blank screen. Where am I going wrong?

dranos
04-02-2004, 10:41 AM
It worked! By golly it worked!!! I forgot to set the scale and position of the clip map to be the same as the texture map. You saved my life. Really you did.
Thanks