View Full Version : Urgent help... Spreadsheet woes.

03-29-2004, 12:09 PM
Hello fellow mac LW'ers,

OK... so, you know how in versions previous to 7.5c there was an option to select an object as "Unseen by Alpha" in the object properties? Well, so now the only way to do it is through the Spreadsheet. OK, I can deal with that, I like the spreadsheet anyway. BUT... what do you do if you checked something and now it won't un-check??? It tries to uncheck the option, but then immediately reverts to its checked state. Any ideas? (Running 7.5c on 10.3.3). This is the only option that screws up, everything else works fine! And of course, it happens to be the one option that's only available in the Spreadsheet. Grrrr!

P.S.-- I apologize if this has already been answered somewhere... I looked but couldn't find any answers.

03-29-2004, 12:20 PM
Wild guess, maybe there is a problem with your LWSpreadsheet.cfg? Maybe try removing it from your user library prefs folder and see if that helps.

03-29-2004, 12:33 PM
Hi bloontz,

Thanks for your reply. Unfortunately it didn't solve the problem. This is driving me nuts. Well, I solved the immediate problem (short deadline and all, had to do something quick.) I opened the scene file in TextEdit and did it manually. For my own sanity... surely there has to be an easier way?

03-29-2004, 02:37 PM
Well, I've discovered that playing with the scene file in text mode can be pretty fun, and it makes me feel like a good geek.

I ran into a second problem... I wanted to change a bunch of objects to act as "cut outs" or masks, so the camera wouldn't see them but they would subtract from the alpha channel. Well, the only way I found to do that was to change the Alpha Channel setting under "Object Properties/Render" tab to "constant black". Well enough, but I have over 200 objects in my scene to change. Went to the Spreadsheet again... and for the second time today, it gave me a headache... I couldn't find that option at all!

So... this is what I did. Changed one object to "constant black". Closed scene. Opened scene in TextEdit. Discovered that this property adds a "ObjectAlphaMode 2" flag to the object. Did a good ol' "Find/Replace", saved, closed, and opened again in Lightwave. The scene is now rendering with all the proper alpha settings.

So... what am I doing wrong?? Surely it can't be this hard. Anyone?

03-29-2004, 02:46 PM
Don't worry, it's not you!

The "unseen by alpha" option used to be a checkbox in 7.5. In the update to 7.5c, this option was changed to a dropdown box with the options you currently see. Unfortunately, the spreadsheet was never updated to reflect this change. Hopefully LW8 will fix this. This affects both PC and Mac.

Someone else just pointed this out recently also:

03-29-2004, 05:51 PM
You could also select all the surfaces at once and use the alpha settings in the advanced tab -

Triple G
03-29-2004, 06:14 PM
It's definitely not you. Just another bug that slipped through the cracks.


03-30-2004, 07:43 AM
Hey everybody, thanks for your replies. I'm glad to know it wasn't just me! A frustrating problem, for sure...