PDA

View Full Version : Can't customize UI colors in Mac LW



tingham
03-25-2004, 07:45 PM
I found the tip at: http://www.menithings.com/manual/config.php?action=how and I'm really interested. It seems like you should be able to configure lightwave to say, look similar in appearance to Apple's "Pro" UI.

However, I can't seem to make the necessary changes, as there is no lwhub.cfg, and furthermore, no place it appears to put this information. The cmdLine file does not produce the desired result.

Any help would be appreciated.

-Thomas

wapangy
03-25-2004, 09:46 PM
Use the "LightWave Hub Prefs" in your preferences folder. However, I'm not sure if it still works on the current versions of lightwave, I can only get it to change one button color, or the background, and nothing else.

toby
03-25-2004, 09:59 PM
These work for me, (in the Hub Pref file):

BackgroundColor 100 100 100
ActionButtonColor 125 125 150
DialogButtonColor 100 125 150
DragButtonColor 140 165 140
InfoAreaColor 80 80 80
StateButtonColor 194 194 194

I didn't change 2 of the button colors, but I'm sure it would work for all three

wapangy
03-25-2004, 10:25 PM
I still can only get the backdrop color to work, I've tried completely new preference files and everything, have not been able to get it to work for a long time now.

tingham
03-25-2004, 10:50 PM
Originally posted by wapangy
I still can only get the backdrop color to work, I've tried completely new preference files and everything, have not been able to get it to work for a long time now.

It seems strange that this isn't working. Can you provide us with the full path to your Prefs file that allows you to procure these changes?

toby
03-25-2004, 10:58 PM
users/your-name/library/preferences

Save some back-up preferences first

hard to believe they don't work for you wapangy - are you sure that LW isn't looking somewhere else at some other pref file?

wapangy
03-25-2004, 10:59 PM
Its using the prefs in harddrive/users/me/library/preferences
I used to set the cmdlines to have the prefs in the programs folder, and it had the same results.

tingham
03-25-2004, 11:16 PM
Originally posted by wapangy
Its using the prefs in harddrive/users/me/library/preferences
I used to set the cmdlines to have the prefs in the programs folder, and it had the same results.

Well, it appeared that before everything was coming out of the LW directory, I see now the folly in my assumption.

-thomas

wapangy
03-25-2004, 11:58 PM
Ok, I got it working. There was no problem with were the preference file was. Its all about the format of the file.
How you guys edited the file is beyond me. I know that you can use .rtf which is what textedit likes, and in the past I always had textedit treat it as a .txt file, and that worked, but it messed something up now for some reason. I also tried subethaedit (great for .txt editing by the way).
In the end it looks like none of that works like it used to. I only got it to work by using worldtext (installed with the developer apps), and saving as "simple text compatible". Thats the ONLY way I could get the file to be read right. Its all about the returns at the ends of the lines, I could only get background color to work because it was at the top, and it would ignore everything after that.

Anyway here is a good link for colors, http://www.auroragrafx.com/LW/LWColorCfgs.htm

I like

BackgroundColor_____ 080 080 115
StateButtonColor_____ 080 080 100
ToolButtonColor_____ 080 080 100
ActionButtonColor__ 120 120 140
DialogButtonColor__ 080 080 110
DragButtonColor_____ 160 170 190
InfoAreaColor__________ 115 115 130
InfoAreaTextColor___ 255 255 255

tingham
03-26-2004, 12:16 AM
I believe it's related to line endings somehow. Although BBEdit show's mine as Macintosh.. strange.

=t

toby
03-26-2004, 12:21 AM
I can't stand Texedit, it'a pain in the @$%$ to get anything but a stupid .rtf file, which I wouldn't expect any program to read code from, get BBedit Lite and throw Textedit in the garbage.

Ade
03-26-2004, 07:04 AM
I still cant get it to work Sheesh!

I want this config:

BackgroundColor_____ 129 129 129
StateButtonColor______092 092 092
ToolButtonColor______208 208 208
ActionButtonColor____141 141 141
DialogButtonColor____208 208 208
DragButtonColor______092 092 092
InfoAreaColor__________ 060 060 060
InfoAreaTextColor___ 000 000 000


If someone can get it working email it to meeeee!

[email protected]

wapangy
03-26-2004, 11:02 AM
I've attached my file.

Another key is to make sure there is only one space between the numbers and name, and none after the three numbers... stuff like that.