PDA

View Full Version : Two questions on Zoom and Focal Plane



etyrihje
03-25-2004, 09:00 AM
My current project is a Point-Of-View shot through a peep hole in a door,

1) I want the peephole to fill more or less the entire frame, but if I move the camera that close it gets x-ray vision and doesnt render the door and peephole.

When I move the camera back and try to zoom in (to make the peephole more or less fill the frame) the same happens again...

The camera is well back from the wall with the peephole, any thoughts?

2) When I started out learning LW I am sure I could see a circle illustrating the current Focal Plane, making it easy to set correct focus, now I cant seem to find where to turn this feature on...

BeeVee
03-25-2004, 09:21 AM
In the Display Options for LightWave set the Near Clip Distance.

B

mkiii
03-25-2004, 09:35 AM
1) First of all, check the Fixed Near Clip Distance in the Display options panel. This affects the Ogl display only, just in case your problem is display rather than render related.

maybe you should move the camera a bit farther away & use the FOV / Zoom settings to peep through the keyhole.
If you don't need to view the door before you peep, why not just remove it & use a foreground image in the shape of a slightly blurry keyhole, or parent a clip mapped poly to the front of the camera at an appropriate distance

2) What you probably saw was the Camera Mask Custom Object, which can be used as a focus aid, (or possibly the cone of a spotlight). To get at the Camera Mask, go to the Items Tab, and Add, Custom Object, Add
Camera Mask & select your camera as the Item. (see manual p 9.2)

Alternatively, Create a Range Finder custom object. Now you have a numeric readout of the range to that custom object. If you need a constant distance to an object, just parent the range finder to your object.

Lightwolf
03-25-2004, 09:51 AM
2) Depth of Field Custom object:

- Create a Null, parent it to the Camera
- Apply the "Depth of Field" Custom object to it.

Mind you, it will only display the correct depth of field if you set the final render size in the Camera panel.

Cheers,
Mike