PDA

View Full Version : Where's the Panther speed boost for G5?



Johnny
03-22-2004, 07:16 PM
This past week, I upgraded the Dual G5 and Dual G4 to Panther, 10.3.3...

I began Screamernetting almost immediately, and noticed that the G5 was only about 3 times as fast as the G4, on average..this is about as it was when both Macs ran 10.2.8.

Shouldn't the speed diff. between G5 and G4 be even greater with G5 running Panther?

Maybe one doesn't see this with LW 7.5c?

J

Ge4-ce
03-23-2004, 12:52 PM
I think panther is both G4 as G5 optimised, so the speed difference will be only based on raw machinespeed. Apple has currently more G4 chips in circulation than G5's so if they were doing an optimize only for the G5, crowd would go like: " hey.. you need a G5 to run panther" and that means.. lots of cash going lost..

About the panther is G5 optimized..??? : Just plain marketing.

what you DO notice is Apps being optimised for G5 (shake, FCP and DVDSPR and hopefully LW 8 soon) there are about 30% renderspeedincrease reports between FCP 4 and FCP 4.1 just based on software

Ade
03-24-2004, 12:15 AM
Rendering is purely mhz speed.

The g4 has a much more robust altivec regsiter comapred to the g5. This was because g4 needed to compensate for its small bus with a crazy fast alitvec mode.
Maybe try th new screamernet controlers on offer, theres screamernet controller and render farm cntroller.

fxgeek
03-24-2004, 05:33 AM
Originally posted by Johnny
This past week, I upgraded the Dual G5 and Dual G4 to Panther, 10.3.3...

I began Screamernetting almost immediately, and noticed that the G5 was only about 3 times as fast as the G4, on average..this is about as it was when both Macs ran 10.2.8.

Shouldn't the speed diff. between G5 and G4 be even greater with G5 running Panther?

Maybe one doesn't see this with LW 7.5c?

J

No.

You'll only see a difference when Lightwave is optimised. Rendering wouldn't be affected by the kind of Optimisitions that would be in panther which would mostly affect screen redraw, quartz effects and such things.

Panther did have more programming hooks in it to allow third party developers to exploit the G5 more, so it's likely that LW8 (have the system requirements been released yet?) or the optimised version that follows it (8.1 or whatever) will require Panther.