View Full Version : Viper & Surface Editor problem

03-15-2004, 11:38 AM
I am experiencing a strange and I hope solvable problem. In one scene file, and one only, I get a black screen in viper and the surface editor preview. I at first thought that viper was not rendering because the surface editor was not open. I opened it thinking that would solve my problem but only revealed the second issue (blank editor preview). I spent an hour opening scene files and was unable to repeat this problem with any other scene. Are there variables that could be reset? I am grasping at straws at this point as I have some volumetrics to update but the lack of viper/editor is making it hard. I installed FPrime this weekend and thought that might be causing an anomoly but once again all is fine in other scenes. thanks, mokba

03-15-2004, 11:48 AM
Are you getting a black screen when you do an F9 render?
Do you have Enable Viper checked in your Render Options panel?
Do you have Use Scene Lights checked or unchecked in the Surface Editor options?

03-15-2004, 02:43 PM
F9 results in a render, no problems. I do have Enable Viper checked in the render options panel. I hadn't thought of the Scene Light question. I will check into that and let you know.
gracias, mokba

03-15-2004, 05:31 PM
The 'Use Scene Lights' is checked and still black screens. If I enable checkerboard as the background in the surface editor I do see the checkerboard with a black sphere in front of it regardless of which surface is picked. The checkerboard also shows up in the viper window with a black profile of the objects in the scene. This is the weirdest thing I've ever seen. mokba

03-16-2004, 08:31 AM

Do you see a preview if you uncheck Use Scene Lights?

03-16-2004, 07:42 PM
I unchecked use scene lights. The preview now shows and all objects show in viper with the exception of the image I am using for a background. At least I can see the volumetrics in viper so I can get some work done on this scene. I don't know why I can't see my background image when I have been able to in the past. I have been comparing all settings between scenes that are working (a herculean task) but have yet to figure that one out. Thanks very much for the help. mokba

03-16-2004, 08:01 PM
It's strange but I had exactly the same problem earlier today. No surfaces were viewable in the preview, renders fine but viper showed the same lack of surfaces, just a totally black sillouette.
I don't have fPrime but the only thing I did different with that scene was render it with GI monte carlo, a function I never use due to the time constraints, but I wanted to run a test to see what result i would get and what time was involved.
I'm presuming if you've got fPrime you've been playing around with GI too. Could that be a common factor?

03-16-2004, 08:42 PM
cagey5, good thought. I tried turning off all radiosity. I still get surface previews and objects in viper with use scene lights unchecked in the surface editor options, but no background image in viper. Strangeness abounds. mokba