PDA

View Full Version : skelegons & pitch rotation



bluehand
03-08-2004, 09:39 AM
When I create my skelegons in Modeler, I realize that the pitch rotation is dependent upon which view I use to create the skelegons. When I create the bones from the Front view, the pitch rotation isn't the same for all of the bones. When I create the skelegons from the Top view, the rotation is the same for all of the bones.

Also having trouble with editing the rotation of a skelegon in Modeler. I can move the handle and make changes, but can't seem to change to rotation of the first bone created in a chain.

* sorry no image for reference - I tried to attach one, but for some reason, it didn't upload. I also tried placing the jpg on my personal web site, no luck...it sure is monday!

Axis3d
03-08-2004, 04:53 PM
You should be able to rotate any of the Pitch handles of bones in Modeler using the Edit Skelegons tool. If some bones are too small, zoom into them really close and you should be able to see and manipulate the handle. After you make adjustments to all of them, make sure you hit the 'enter' key and not just hit the spacebar to drop the tool, or else the changes will not take.

lw_werewolf
03-08-2004, 05:12 PM
build a good skelegon set up is not difficult.
remember that pitch bone depend of view used to build bone, to understand better, try to build a bones chain in all of three view of modeler, and check the pitch direction, you can see it depend of original view used to build it.

when you load it in layout, verify that parnt in place is off, and use record pvrot, to reset start rotation angle of bones.

i hope that newtek understand that in a modern software, like lw (for the future), is not possibile that there is an only one axis where apply compensation, but it's better if add a simple requester where you can decide what axis must be corrected with deformer.

bluehand
03-09-2004, 05:06 AM
I've rotated the handles. It was still coming into Layout looking like this. I'll try again to post my screenshot. Top part of each shot shows the skelegons in Modeler, then below is how they look in Layout. Left side is when I draw the skelegons in the Front view, right side is when drawn in Top view (when drawn in Top view, they come in correctly). I've checked the pitch handles in Modeler, and still they didn't come into Layout correctly, like the handles - I've had all the handles line up, and would still have a few of the bones have the pitch rotated.

jeanphi
03-09-2004, 10:02 AM
When you use the "edit skelegon" tool in modeler, if the "bank handle" is lock, go on perspective view and "MMB" on the "bank handle". This will reset the "bank handle". Then you can edit all of them freely in ortho or pers view.

bluehand
03-09-2004, 07:17 PM
Thanks to everyone for their help and suggestions, but it's still happening. I attached another screenshot. Showing that in Modeler, all of the handles are lining up. Yet, in Layout, the first bone has the pitch different than the rest.
* I made sure that "parent in place" was unchecked