PDA

View Full Version : No smothness



jaxtone
03-05-2004, 07:39 AM
http://www.salmins.com/images/robotstand.jpg

This is a robot stand modeled in a industrial CAD system. Saved as a STEP file and then imported into Rhinoceros before I exported it as a Lightwave object.

Strange enough I cant get rid of the sharp surfaces on the object. I have tried to change the smoothness angle but nothing helps. What might be the problem except from me being an ignorant ;)


J

murdoch
03-05-2004, 07:43 AM
looks like a flat shaded view, try changing it to smooth shaded

Kurtis
03-05-2004, 07:47 AM
Are all the points merged or welded together? It's not all existing as individual polygons, is it?

You might also want to check for two-point polygons at the intersections.

jaxtone
03-05-2004, 07:49 AM
Its not a flat shaded view.

Juris

jaxtone
03-05-2004, 08:02 AM
Hi!

Youre damn right, there are a lot of points at every edge of each polygon, there seems to be 4 points at most edge. I tried to merge a few of them together and the surface went smoother directly. Im impressed by your knowlegde!

The problem is that there is exactly 62 239 points in this small part of the robot, and I cannot merge these four by four or similar without missing the deadline.

I remember about 5 years ago from now when I produced an animation scene project for a shipping company. There were almost 4 million points doubled in all parts of the scene so I had to reduce the amount to make Lightwave work properly. I couldnt manage this in Lightwave so I had to ask one of the 3DMax guys and he solved it easy as hell.

It was some kind of multi merge point function and I admit it took time but it worked.

So my next question would be, is there a function in LW I dont know that can merge all these doubled, tripled or quad points to meet my desired one point at each edge? Or am I out of businness?

J

Kurtis
03-05-2004, 08:08 AM
Modeler>Construct>Merge Points (keyboard shortcut m)

There are two options for Merge Points, Automatic and Fixed.

Automatic will merge all points that are in exactly the same spot. Try this one first.

Fixed allows you to establish a distance of how far apart points can be and still be merged. Try this one second. One thing to be careful about, if you set the limit too high, you'll merge points you don't necessarily want merged. You might want to practice on some copy objects first.

jaxtone
03-05-2004, 08:15 AM
Am I stupid or what? Just found it and it seems to be a little tweaking around to get this right.

You rock! Thanks!

J

Kurtis
03-05-2004, 08:33 AM
No problem. Glad I could help.