View Full Version : modeler will not save

03-03-2004, 04:32 PM
For some reason Modeler will no longer save any changes I make to any models. I can change them, but after "saving" the changes do not take effect once I reload the model. Lightwave itself will not accept these changes, nor will the two programs even communicate via the Hub anymore. Actually, Lightwave will send the model back to Modeler, but not vice versa. Also, the model sent back to Modeler is STILL THE OLD MODEL no matter how much I change it even in Lightwave itself. WTF?

AND another problem: half of my bones do not show up in the scene editor! they are there in the window but not in the scene editor. how impossible is that?

03-03-2004, 06:15 PM
Check and make sure that LightWave has not slipped into Demo Mode/Discovery Edition.

Are you using the Save All Objects command in Layout?
If you change the object in Modeler, and use Save Object, are the changes saved if you reopen the model in Layout or Modeler?
Does this happen with all objects and scenes, or only particular ones?

What kind of graphics card do you have (make, model, onboard RAM), and how current are the drivers?
What version of LightWave are you using, including any updates?
What operating system are you using, including any updates?

03-03-2004, 06:46 PM
First of all, the Hub has always been iffy to me, I never use it. I have also found that opening a scene that contains a model that I just modified in modeler often does not reflect the updates. I usually resort to deleting the object and reloading it.

03-03-2004, 08:32 PM
for mattclary:
im sorry, but i find your comment completely unhelpful as the hub has always worked before, else i would have listed IT as the problem, not modeler.

as for kurtis, thank you for more help, but:
LW is not in demo mode.
i use the same commands as i normally do, i have saved the object (with any change) in separate files and none represent the changes.

HOWEVER, if bones are modified and deleted in Lightwave and saved as a scene, then the changes stick... this is however useless in modifying the actual model in Modeler, since LW cannot change geometry.

it now happens with ALL models.

my graphics card is a Radeon 9200, LW 7.5C, WINXP, All updates

03-04-2004, 08:18 AM
Ok, I am trying to understand what your dillemma is, but it is a little confusing. If I interpret what you are saying correctly, you are taking a object from Modeler, and sending it to Layout, making some changes in Layout, and then sending the modified object back to Modeler. Is this correct? If so, what changes that you are making in Layout do you expect to see in Modeler? The only changes that you can make in Layout that affect the object file that you are working on are surface properties, and even then you must do a "Save Object" from the Layout menu. If you are trying to save mesh deformations from Layout, then you would need to "Save Transformed Object," and preferably save to a different file name so that you can still have a copy of the un-deformed object also. HTH

03-04-2004, 08:23 AM

I think probably all mattclary was trying to say is that it's always best to rely on normal procedures, and use the Hub as a backup.

I asked if you had somehow slipped into Demo Mode, because the Hub will not work properly in Demo Mode, and it's easy to not notice if something has happened, like the hardware lock or it's driver going bad, that has caused you to drop down into that mode.

Have you made any changes to your system recently? Added new hardware, added new software, etc.?

Have you tried resetting your LightWave config files?

03-04-2004, 01:04 PM
Originally posted by myridnir
nor will the two programs even communicate via the Hub anymore

Hmmmm... sounds like there might be a problem with the Hub...

Originally posted by myridnir
Actually, Lightwave will send the model back to Modeler, but not vice versa.

How are you "sending" the model? The Hub, by chance?

Not sure why I warranted such a rude response. It may not have given you the info you needed to fix the problem, but more information on people seeing similar behavior is usually helpful, at least to me.

If you aren't using the hub at all (which I don't), did you read the second half of my post?

03-04-2004, 05:21 PM
sorry, matt, i was just having a terrible day and took it out on you. :-(

as for the other posts, it has not gone into demo mode as far as im aware, nor have there been any hardware or software changes.

my post might not have been specific enough, so I will elaborate:
when i make any changes in modeler and hit save (or type s) the changes are not actually saved. in layout, however, i AM able to change certain aspects of the model (surfacing, etc.) but the model itself cannot be modified because modeler will not actually save the new data.

the part i am attempting to change is itself an oddity: i am trying to delete a ghost-object. there are skelegons that i did not create in the model (there are those i did in there too, but im leaving them). i delete the extraneous information and save it, only to find them back when i reopen the model later.

03-04-2004, 06:57 PM
have you tried trashing your LW and modeler preferences? have you tried cutting the object/s into a new file and saving, maybe with a different name?

03-04-2004, 09:14 PM
i think i did state before, but am not sure, that yes i have saved into a different file name. i am in the process of trashing the cfg's and prefs now and will let know what happens afterwards! thanks!