PDA

View Full Version : Screamernet saving problem



kezo
02-23-2004, 07:42 AM
Hi,


having problem with screamernet output/saving. manage to save the render output to local disk if I place the render node same as the screamernet server. but whenever I move the same LWSN script to another render node it can't seem to save to the locaton specified altho it shows (on the screen) the file has been written to the destination folder. My screamernet server is running on MS Windows server 2003, nodes on MS windows xp professional, I have set the security access to full control for all the nodes. Scanned all the plugins a millions time. still there is no output from the nodes. what could be wrong?

this is the LWSN script I executed. Seems to be working fine for me

@echo OFF
echo "LightWave ScreamerNet Node 1 Initialisation . . ."
cd c:\lightwave\programs\
LWSN -2 -c\\server\screamernet\config_sn -d\\server\screamernet\ \\server\screamernet\screamer_command\job1 \\server\screamernet\screamer_command\ack1

hdesbois
02-23-2004, 10:40 AM
Hi,
Seems to me you have a path problem somewhere in your config files.
Check this one :
http://www.newtek-europe.com/Stuff/LightWave/Misc/MattGorner_ScreamerNet_Tutorial.pdf
I actually had the same problem the first time I tried screamernet, and this tut was of great help!
Good luck
HD

Riplakish
02-23-2004, 05:03 PM
How are you "rendering" your output? Are they stills (JPG, TGA, etc.) or animation (AVI)? Lightwave render nodes will only render still frames. Typically,
you'll render to 32-bit TGAs, and then use Lightwave or another program to reassemble them in sequence in to an AVI.

kezo
02-23-2004, 11:16 PM
thanks for the replies

hdesbois>
yeah I did followed Matt's guide but I cant find which part of the config path is wrong. any idea?

Riplakish>
I render it as image file aka Jpeg

hdesbois
02-25-2004, 02:57 AM
Hi kezo,
Another thought... If I use a windows XP (home) node, I have to log on the server from the node first (for instance, connect a network drive). But I think this applies only to XP home because of poor network functions. Even if it's not as convenient, did you try to change from UNC to mapped drives?
HD

kezo
02-25-2004, 07:08 AM
yeah I try the drive mapping but couldnt solve the case

hdesbois
02-27-2004, 03:47 AM
Here is my own command line on the second (XP home) node:
echo "LightWave SceramerNet Node 1 Initialisation..."
cd c:\lightwave\programs\
LWSN -2 -c\\Patapon\screamernet\config_sn -d\\Patapon\screamernet \\Patapon\screamernet\screamer_command\job2 \\Patapon\screamernet\screamer_command\ack2
"Patapon" is the name of my server. As you can see, there is no "\" after the directory name. I found this work better, especialy regarding memory use (don't know why). I suppose you already scanned all your config files for strange path names?
You can also dowload spider networks from
http://www.stationx.com/index.htm
Since you are running XP pro, I guess you can use it. If the network setup fails, just install locally on each node. Ignore the error message during the isntall (the one about a dll already in use).
Good luck,
HD

TheDAve
03-26-2004, 09:07 AM
Hi kezo,

Did you find a solution to this problem?

Since I'm having the same problem.

I just spent a day getting ScreamerNer working, I read Matt Gorner's tutorial, I scanned my plugins & I have checked I have write access from the node PC's.

I've scoured the forums - Someone suggested I connected up to the network folders from the node PC's to ensure the nodes are logged on, & I tried that, but it had no effect.

But still the output files do not save except for the PC that also runs the controller.

Controller/Node 1: WinXPPro
Node 2: WinXPHome
Node 3: Win98

Only node 1 saves files.

I know using differing OS's (and processors) is not a great idea, but wanted to get the system working before I tried to rationalise the setup.

Oh & my batch file looks the same as the sample provided by hdesbois.

Any Ideas?

DAve

GruvSyco
03-26-2004, 10:43 AM
I would do the following:

1. Verify that each user on the nodes has full rights to the destination.

2. Try using mapped drives. You can always return to UNC later.

GruvSyco
03-26-2004, 11:49 AM
here is an example of what my Node batch file like:

## Launch a Screamernet node
## Edit the directory paths to suit your system
echo init >z:\command\job1
LWSN.exe -2 -dz:\ -cz:\lw3.cfg z:\command\job1 z:\command\ack1

for each node, I increment the job and ack # (i.e. Node1.bat has job1 and ack1, Node2.bat has job2 and ack2, etc.)

The way I have it set up... everything is on the host (my primary lightwave installation... that is shared). The only thing on the nodes is a shortcut to the .bat file that is in z:\programs (aka c:\lightwave\programs on the host)

GruvSyco
03-26-2004, 12:13 PM
also you need to make sure you change your path in the config files you placed in the content directory...

I copied my lw3.cfg and lw3ext.cfg files to my shared content directory (drive z: ) and did a find and replace on them... c:\lightwave\ = z:\

TheDAve
03-28-2004, 05:33 AM
GruvSyco, cheers for the mapped drive suggestion...

It lead to me finding the solution, but the cause was unexpected.

I thought I had checked all the permissions, and accesed all the shares from the nodes, but I'd forgotten to try to access the shared lightwave folder (to allow access to the plugin & lscript folder).

When I finaly tried to access this folder from a node I was not allowed access, even though the permissions were set up to allow everyone read/write access.

After trawling the net I found this (http://www.microsoft.com/windowsxp/pro/using/itpro/managing/filesharing.asp) page.

Which tells us the nice people at Microsoft have decided "The Sharing option is not available for the Documents and Settings, Program Files, and Windows system folders."

In actual fact is seems that you may share folders in "Program Files" folder, but even though you set access rights for these shares you will not be able to connect to them from other computers.

You can share subfolders, so if I install LW to "Program Files\Newtek\Lightwave" I can share & access this folder, but not "Program Files\Lightwave"

So either I have to move my plugins & scripts folders to somewhere I can share, or reinstall Lightwave to another location.

As it is I'll just wait to see what LW8 brings, I just thought I'd pass on this infomation in case it helps anyone else.


DAve