View Full Version : About setting up bones...

02-17-2004, 11:32 PM
I'm modeling bones in modeler and then converting them in layout.

After conversion I set up the parenting and then have the bones connected to the weight maps I put on my character. I then change the "Use Bones From Object" layer to the correct layer my bones are on (when I made them in modeler).

But the bones are still not deforming my character, they dont do anything. What am I doing wrong?

I can explain further if anyone needs me to.


02-17-2004, 11:59 PM
i believe the bones have to be in the same layer as the geometry, (but i'm still pretty new to this so i could be wrong).

02-18-2004, 12:07 AM
howdy slave.

The simple answer to this question is to cut and paste your bones/skelegons into the same layer as your object (in modeller). This automatically creates the connection between the skelegons and the model.

If you're worried about not being able to easily select the skelegons again, you can bring up the statistics window (press "w") and select your skelegons from there.

Also, you may want to make sure that your weight maps are named exactly the same as your bones. Just one character off makes all the difference.

Just as a tip, an easy way to make sure that all of your weight maps/bones have the same names is to go to: Map:Weight & Colour:Bone Weights, then change the Threshold value to 0 and the Use Threshold to 'Clip'.

Bone Weights is an automated weight map setup thing, which is fine if you're creating snakes, but for anything more complicated it really hinders more than helps.

But the above settings create a whole set of weight maps with no actual "weight" applied. Just the correct names! Then you can go through and create all of your weight maps, knowing that all of your names will be correct.

Hope that all made sense.

02-18-2004, 04:55 AM
You don't need to do any of the above. Have you made sure the bones are associated with their weight maps by checking in the Skelegon editor?

In layout, select the object and go into bone selection mode. It should say 'none' in the bone drop down list. Now open the properties panel, and select the layer with the bones in in the 'Use bones from object' drop down. (which is what I think you did, but I just want to make sure!)

Make sure you're not doing it the other way round! ie going into the bones layer and opening the properties panel and selecting the mesh object in the 'Use Bones from object' drop down.

Select of your bones and make sure the relevant weight map is selected in the 'bone weight map' drop down.

If your bones are active, then it should work...

If not, send it on over and I'll look at it.

You DON'T have to have bones in the same layer as your object for them to work!

02-18-2004, 12:06 PM
Okay, Thanks for the replies! :)

I'll try your suggestions as soon as I get to a computer.

For Dodgy:
"It should say 'none' in the bone drop down list. Now open the properties panel, and select the layer with the bones in in the 'Use bones from object' drop down. (which is what I think you did, but I just want to make sure!)"

I have two layers, one with bones and the other with the object. Are you saying for me to select the object layer, then go into Bone selection mode (at the bottom of the interface) and then in the properties inspector it should say "none". THEN I select the bone layer, and then choose (in the Properties inspector) from the "Use bones from object" drop down menu the same bone layer (not the object layer).

One of the wierd things that happened is that I have two objects with their own set of bones. I did the same thing for each of them; one works but the other one didn't. I even restarted Lightwave twice, but nothing.

Thanks again.

02-19-2004, 06:43 AM
Okay, Something worked!!

It's a bit strange, but when I put the skelegons in the same layer as the mesh, and renamed them all the same name as the weight maps, It worked!

So, yeah. I don't know what happened, just a wierd quirk of Lightwave I guess.

One way works for one model and another way works for another model.

Thanks everybody.

02-19-2004, 07:59 AM
You shouldn't have to put them in the same layer as the mesh.

The answer to your question is no. Okay here you go :

1/select your mesh.

2/Click on the bone selection mode at the bottom of the interface. Because you don't have any bones in that layer, the drop down selector just above should say 'none'

3/open the propeties panel (press p)

4/At the top it has 'use bones from object' and you should set that drop down to your bones layer name. This means your mesh object will 'Use bones from' your bones layer.

5/ You do have to make sure if you're using weightmaps, that each bone has it's weightmap selected in IT'S properties panel.
So select each of your bones in turn, and open the properties panel (press p again) and about halfway down there's a Boneweightmap drop down selector. Use this to set the weight map it should affect. Do this for all your bones, and they should work.
Again, they don't have to be called the same as the weight map you want them to affect, just have it selected correctly in the panel. If you have any bones without weight maps selected, they will probably overrule bones that do, as their influences will not be restricted like the bones with weightmaps are.

02-20-2004, 08:57 PM
Umm, yeah.

When I select the object layer and then open the properties panel, There is no drop down list named "Use bones from Object". (Unless I'm blind:P )

This list only exists in the Bones Properties panel, which I can only get to when I select the bones (after converting them from skelegons).

In the "Inside LightWave 7" book, it says for me to create the bones (convert them), then select the bones, and then open the properties panel, and then select the bones layer in the "use bones from objects" drop down menu. (And then select the appropiate weight maps, etc.).

I did exactly this for the first object, and it worked. But for the second object it just doesn't work.

Maybe your'e using another version of lightwave then me. I'm using the mac lightwave 7.5 version.

02-21-2004, 08:19 AM
You're not doing step 2! :)

While you have the MESH selected, which doesn't have ANY BONES in that layer, you can still go into bone selection mode. You can still bring up the properties panel for bones, even though you don't have any in that layer!!! This is so you can select another object from which to use the bones from even though your mesh doesn't have any!!!!

Okay. Say your mesh object is in Object:layer1 and your bones are in Object:layer2.

You select your Object:layer1 and press shift-B to go into bone picking mode.

Now press 'p' and the bones properties panel will pop up, and it should have in the 'current bone' field '(none)'.

Go to the top, and the 'Use bones from object field' will say (self), change that to 'Object:layer2' and your mesh object will now use the bones from layer2.

then continue from step 5.

Is that a bit clearer? :)

02-25-2004, 05:22 PM
Sorry for the late reply. :D

But,... as you can imagine.... you were right.

I should start reading through steps more often.

Thanks for the advice!!

02-25-2004, 05:56 PM
No problem, that's what we're here for :)

Chrome Studios
03-17-2004, 09:26 PM
Hi guys. I've been having related issues since I bought 5.6 for my Mac. In my case I think it's a Mac problem though. I can take a perfectly rigged model I've been using forever, and one day the bones won't deform it. I'm using 7.5 now, and life hasn't changed much. I still love LW and they have worked out a lot of Mac bugs, but sometimes I wonder why I've been using it so many years.

03-22-2004, 04:09 AM
Wow! I just went through hell a few days ago just to figure out what Doggy just explained. It worked great though. But, I think it is a strange way to have to do things (Kinda like an Easter egg, hard to find but cool when you do!)

Hey Dodgy,

Any idea why after initializing my bones in Layout, my characters feetsies both get twisted from the instep to the toes in the same direction? This is my first attempt with bones and I tried a few things like altering the rest rotation and position, but nada. Oh, I used the setup defined in Chris Olsen's tutorial. The problem 'seems' to be with that last little bone between the ball of the foot and the toe. But, Im just guessin.