PDA

View Full Version : Flickering in 3-Pt light setup?



Johnny
02-04-2004, 08:11 AM
Overnight, I did a test pan of a scene with 3-point lighting, and got a kind of flickering from my key light.

Nothing about this light is animated or varied over time. I have shadows turned on, Radiosity, noise reduction, and Extreme High antialiasing.

There also seems to be a light called STK_Sun which I didn't knowingly create, but which keeps coming back into my scene after I delete it (and close and re-open).

Are these separate issues? what's the cause of the flickering..radiosity?

EDIT: I just whipped together another test pan, which is still going, but with Radiosity off, the flickering seems to be gone...does this mean or suggest that Radiosity isn't for use in Animation...just like Caustics, bcs of the flickering from frame to frame?

J

Phil
02-04-2004, 03:46 PM
From memory, the radiosity system in LW is not much for animation because it's slow and causes flickering problems that you are seeing (due to the re-evaluation for each frame).

If you have no lighting changes in the scene (envelopes, etc.), then you can cache the radiosity solution and this should stop the flickering. The alternative approach is to bake the lighting into the surface texture maps, but this also (as far as I am aware) doesn't work with enveloped lights, making it pretty pointless for those kind of scenes.

Caching radiosity is enabled via a gadget in the same panel where you specify the approach (monte carlo, interpolated or backdrop) and the settings.

The more compatible option in terms of render times (shorter) for effect (similar) is to use a spinning light array. You'll find information on this within these forums and via google.

WCameron
02-05-2004, 05:46 AM
isnt this one of the problems that gets fixed if you turn on motion blur and set it to somehting like 0.0001?

- Will.

Phil
02-05-2004, 05:49 PM
Originally posted by WCameron
isnt this one of the problems that gets fixed if you turn on motion blur and set it to somehting like 0.0001?

- Will.

I've tended to find this is potentially slower and is demonstrably less controllable. The spinning light trick is more flexible for sky dome style scenes. *shrug*

I've avoided radiosity in most cases due to the deficiencies and simply used carefully defined lighting rigs in scenes to fake it. I'm hoping, although have yet to see any real information about this, that LW's GI caching modes and the surface baking will all respond more suitably in 8.0, with caching being intelligently managed when light intensities change in a scene and sequences being generated by baking.

Freak
02-05-2004, 09:06 PM
SKT Sun, is Skytracer a light......

Is there a reason you are using, 3PL and Radiosity?
at the same time? What kind of Shadows? shadow mapped?, raytraced?

what about Radiosity, (Monter Carlo, Interpolated, BG?)

You are best to post pictures of the problem, so people can better understand and diagnose them, in case like this....

Generally i don't have too many problems, when using the correct settings, (rays, tolerence's etc..)

Exper
02-06-2004, 04:47 AM
If you don't want the flickering then you must use "Backdrop Radiosity" or "MonteCarlo";
you can even try the "Interpolated" one with Tollerance=0.

"Cache radiosity" helps too!

"Shading Noise Reduction" OFF helps too!

Rendering your scene in a single pass (1 segment) helps too!

Bye.