PDA

View Full Version : Is it difficult to include customizeable interface colors?



little5points
01-17-2004, 09:43 AM
Since I don't know squat about programming/coding and such, I was just wondering if it would be a time-consuming feature to let users color buttons or more specifically, their own menu groups in LW 8.

At work we have a nice palette of color-coded Photoshop Action scripts and I can imagine how nice this would be for LW also.

I'm not opening up a big interface debate again. This has nothing to do with bevel-edges, metallic gradients, etc.

Ross_DD
01-17-2004, 12:48 PM
(sorry for my bad english language)

if i understand well, You want use custom colors in Your LW environment; there is a plugin called "LW Theme Creator" it give possibility of interface-colors customization.
It is a Flash-based application with very simple real-time gui-color modifications.
You can bring this on "Flay".

little5points
01-17-2004, 02:59 PM
Yes, I did know about that but it doesn't let you create a color for a set of buttons. For instance if I made a "Distortions" tab, colored it blue and then colored the subsets different shades of blue or whatever.

Nemoid
01-18-2004, 01:51 AM
Even if changing colors is possible and there are tools wich give the preview of the final UI,
It would be very nice to add a UI options in wich you could decide
things like button colors, button fonts (type and dimension) with a normal color picker, font list and related things. maybe also button dimensions to change them on the fly in a easy way. maybe also these option could be added in the display options panel , or better into a new UI display panel in wich collect all the options regarding what you see on the screen.

Dunno if its easy or not. I think Lw could change the colors and other things in the related config file.

Ross_DD
01-18-2004, 04:55 AM
Hi,

if You want a complete customization of LW user-interface (menus, keys and colors) You can edit LW configuration-files (".CGF") in Your user-directory:
if You are a PC user (Documents and Settings/username) or Mac user (sorry but i don't know with precision...) You can edit "LWHUB.CFG" with a simple-text editor:
in it You can add the same text-strings that You bring in "LWTheme Creator" with Your favourite RGB colors per every text-string:
my favourite color-scheme is:

BackgroundColor 128 128 128
StateButtonColor 140 160 180
DragButtonColor 170 180 190
ActionButtonColor 150 160 170
DialogButtonColor 140 150 160
ToolButtonColor 180 180 200
InfoAreaColor 125 130 135
InfoAreaTextColor 0 0 100

Please, backup Your original "LWHUB.CFG" for any inconvenience, if You want it...

For menus and keys You can create Your favourite settings in Layout and Modeler directly and save it in an appropriate folder ("content dir/settings" or whatever You wish...).
Always You can come back in original settings with pushing on "default" buttons...

Hope is useful...

(sorry for my bad english language)

eFFeFFe
02-19-2004, 05:47 AM
Hi ... I tried to change to colors by editing the preference files. On PC this is no problem, but on OsX 10.3.2, those color values are not used in Lightwave/Modeler and everytime when you quit the Hub, the preference file is reset to it's original state, leaving out the lines about the interface colors ... hmmm ... can't find a solution for it ...

eF,

Nemoid
02-19-2004, 09:06 AM
you must change these values with Hub
and modeler closed, and make the
updated .cfg file only readable.
otherwise Hub rewrites them.

I'd like more to have options for colors
and other things built in in my display
options , though.

Carbon71
02-19-2004, 11:00 AM
That's a nice color scheme Nemoid

Thanks for the cfg info. :)

eFFeFFe
02-19-2004, 02:42 PM
It's strange .... I've done it that way, editing the preference file when none of the Lightwave programs are open (hub ... ) and I've also made the preference file 'read only' ... but it doesn't read the lines of the interface colors and after quiting all (hub ... ), the preference file is reset (not if it's 'read only', but colors still are default) .... Maybe a text format problem ?

eF,