PDA

View Full Version : Transparency with 32-bit texture



bumper
01-10-2004, 03:00 AM
I'am trying to render a grid with LightWave.
The grid is a quad polygon with a 32-bit TGA texture of a grid, but LightWave draw the alpha=0 part of the texture :(

I would like the grid cast shadow on the floor, but if lightwave don't use the alpha channel of the grid texture, it is impossible.

I have set the blending mode of my texture to alpha but it don't work. Is there other parameter to change ???

Thanks in advance.

PXLPSH
01-10-2004, 04:47 AM
No need to use a tga file, Just save a black and white copy of your grid texture as a jpeg and apply it to your object as a clip map.

objects>item properties>render>clipmap

it will clip out the areas that are white.
also make sure that double sided is checked in the surface panel or it wont cast a shadow. you can just control the color of the grid through the surface panel so no need for the tga file as it will
just take up resources.



hope this helps//

bumper
01-10-2004, 07:08 AM
Thank you PXLPSH, this helps me a lot.

Jaffro
01-10-2004, 10:22 AM
i agree with PXLPSH, that is the best way to do it.

Just a note to remember tho; Lightwave will use the tga alpha channel if you need it. I think the problem is that when you load the image it defaults to disable the alpha channel. You need to go into the Image Editor (CTRL+F4) and set 'Alpha Channel' to enable. Then lightwave will use the alpha channel stored in the image. But personally i think its always best to devide up the images, as PXLPSH said, into seperate alpha and colour jpgs.

bumper
01-10-2004, 12:38 PM
Jaffro> LightWave defaults to enable the alpha channel if the image is 32-bit but it don't work.

I will use the PXLPSH method.