View Full Version : Respower Support Questions

01-08-2004, 05:05 AM
I've been trying Respower out over the past few weeks and running into a number of problems.

I can't delete files off their server, even using 'Take Access', it only occassionaly works.

The 'Render Wizard' has an annoying bug for Mac Users, after submitting your render the browser get's stuck trying to load the confirmation page and you have to quit out of the browser and fill the form out again. You have to do this everytime without fail regardless of IE or NS.

The only renders that seem to work are small ones. All of the important stuff ends up in the 'Dead Bin' and the dead logs are next to useless. Not listing which objects have failed to load or what's going wrong.

To test my scene I've download the unpacked version from the Respower 'Source' folder and it's loaded fine first time from my desktop.

Anyone else have any LW/Respower stories to share? Alternative Renderfarms??

I hope these are just teething problems, but at the moment it's not looking good.

01-08-2004, 06:34 AM
I've used respower twice and ultimately got what I needed. It's been a few months but I don't remember any major problems. It did take a while to download the finished files. :)

I'm using a PC and didn't use any 3rd party plug-ins.

01-08-2004, 06:56 AM
Hi dwburman, yeah I'm not using any plugins or shaders, not using Radiosity or GI. Just a simple test scene. That's the way it goes.

01-08-2004, 08:05 AM
I've used respower on two major projects rendering well over 1000 frames total (many of which were 2880 X 480 pixels) some even using hypervoxels and have had nothing but success with them.

It DOES take a while to become accustomed to the interface - using HTML files to setup a render cue is awkward, but everytime I came up with a problem, the people at Respower were there to answer my calls.

I work in Tokyo and sometimes I was calling them in the afternoon (my time) and waking the guys up. Even at three in the morning, Early (his name suits him well) would jump out of bed, run over to the office and help me work out a problem. They are there for you.

I cannot recommend Respower more strongly than that. They get a perfect score in my books.

01-08-2004, 08:31 AM
Jerome -

Thanks a bunch for your kind words. One should note that Ricki has not called us for any support and sends emails instead. We welcome any and all phone support calls.

In our defense, I should note that the problems that he has mentioned are because he keeps uploading corrupted files to our server. Big or small jobs will not run if the files are corrupted. Also, deleting files from our server will be problematical if they are corrupted. We noted this in a support email to him, and explained exactly how to find out why a certain job has failed. To reiterate: one can view why any individual frame has failed by clicking on individual frame logs. We capture the text output of Lightwave's console renderer, lwsn.exe.

In the case of the test frame he tried to run last night, he ran into the same problem. It says right there on our web site:

LightWave command: load.
Loading "Y:/riki//renders//layer_03_main/layer_03_main_mng.lws".
Error: Object loading failed.

This is the same issue he had last time he tried to run something on the farm.

He also ran a test with the incorrect content directory:

LightWave command: load.
Loading "Y:/riki//renders//layer_03_main_1/layer_03_main_mng.lws".
Can't find "Objects/ground.lwo".Can't find "Objects/shell_01.lwo".Can't find "Objects/shell_02.lwo".Can't find "Objects/shell_02.lwo".Can't find "Objects/ground.lwo".Can't find "Objects/ground.lwo".Can't find "Objects/spine.lwo".Can't find "Objects/skydome.lwo".Can't find "Objects/spine.lwo".Can't find "Objects/ground.lwo".Can't find "Objects/ground.lwo".Can't find "Objects/space_ball.lwo".Can't find "Objects/ground.lwo".Can't find "Objects/ground.lwo".Can't find "Objects/storm.lwo".Error: Instance creation failed. There are no MORF type VMAPs in object storm
Can't find "Objects/roots.lwo".Can't find "Objects/shell_01.lwo".Can't find "Images/cobwebs.tga".Can't find "Objects/rocks.lwo".Can't find "Objects/rocks.lwo".Can't find "Objects/rocks.lwo".Can't find "Objects/rocks.lwo".Can't find "Objects/rocks.lwo".Can't find "Objects/rocks.lwo".Can't find "Objects/rocks.lwo".Can't find "Objects/roots.lwo".Can't find "Objects/ground.lwo".

Task processing failed:
Error message found in screamer output
(std exception:_STL::runtime_error)

In this particular instance, rocks.lwo, spine.lwo etc., are not where LWSN.exe is expecting them to be. The content directory was specified as "/", the root of his FTP folder. The actual content directory was something else entirely.

I could go on, but the bottom line is, you need to call us if you have a problem and need some help figuring it out. As it says on our front page under "system requirements:"

Basic understanding of how network rendering works for your 3d animation package

If you do not have this basic understanding, then call us! We'll help!

01-08-2004, 08:36 AM
Hi Riki,

I understand your frustration, and believe me we do everything we can to make the system as usable as possible. I personally came in to the office at 2:00 am yesterday to help a customer who ultimately spent $20.00 on his render, and will gladly do the same for you. As I always say, please do not hesitate to call us at any time, 24x7, for technical support. Our personal cell-phone numbers are on our website, and on the answering machine in our office. I can't possibly stay awake 24x7 to answer e-mail, but I don't mind being woken up if my customer has hit a problem.

For the "Take Access" issue that you're seeing, I suspect that you are using an FTP client that does not empty out a directory before trying to delete it.

For the "Render Wizard" bug, we have purchased OS/X in an effort to reproduce and eleminate the bug. Believe me we're working on it! We obviously don't like a bug that makes it difficult or impossible for a user to place an order :)

As for not listing which file has failed, that's true - Lightwave has an annoying habit of simply saying "Object Loading Failed" and not saying which object, if the .lwo file is corrupt. We simply pass back to you what Lightwave tells us. But as I have done for you on 2 occasions now, I am perfectly willing to load your files in Modeler, one at a time, to figure out which object is failing to load and let you know. Again, if you're under a deadline, don't hesitate to give us a call, I will *always* be glad to help out in any way that I can.

01-08-2004, 09:03 AM
The least I could write about Respower guys is that they are gentlemen.


01-08-2004, 10:38 AM
Respower saved my butt more then once on a project....No problems onmy end!

01-08-2004, 02:57 PM
Thanks for the reply Jerome.

One should note that Ricki has not called us for any support and sends emails instead.

I'd prefer not to make expensive long distant calls to the US if necessary. Besides I'm in a completely different time zone. I don't think anyone would appreciate a call at four in the morning. I can't see anything wrong with contacting support via email.

In our defense, I should note that the problems that he has mentioned are because he keeps uploading corrupted files to our server.

I downloaded all of the unpacked files from the Respower server using the latest version of Fetch and they all opened fine on my system.

Also, deleting files from our server will be problematical if they are corrupted

It's not just the one file that I can't delete from your server. I've had trouble deleting other types of files.

To reiterate: one can view why any individual frame has failed by clicking on individual frame logs. We capture the text output of Lightwave's console renderer, lwsn.exe.

In the case of the test frame he tried to run last night, he ran into the same problem. It says right there on our web site:

I know this already, but you also know that the log doesn't specify which object failed to load. I'm not saying that's your fault, but please don't make it sound like it's all there in black and white, because it isn't. Where in the log does it specify that ground.lwo failed, it doesn't. So how can I find which file is causing the problem and deal with it? I can't. It's that simple.

He also ran a test with the incorrect content directory:

To be very clear on this. All of the renders that I've attempted have used the correct content directory. At the end of my session there was one final attempt where I intentionally changed it to 'Source'. It was just one stupid last ditched attempt at the end of my session, after I had exhausted all logical options.

It has nothing to do with the problems I've referred to in this post.

01-08-2004, 03:12 PM
Ricky -

I think that if you'd rather not spend money on a long distance phone call (which we don't mind receiving at 4:00 am), and would rather complain about our service on a web site rather than resolve your problem, then our service is not for you.

I suggest that you go to rendercore. You have to call them in order to set up an account. You can also call efxone. They, too, require that you call them to set up an account and to schedule time. While these calls are long-distance, perhaps in the long run you would be happier.

As for self-service competitors, there are none. Feel free to set up your own company and make a self-service render farm. Then you, too, can know the joy of having to deal with... well, best left unsaid.

As for your particular problem, Lightwave does not tell us what the corrupt object is, therefore our system can't know. Unless you call us and ask us to manually check for you (as Early said he'd be happy to do), there's no way anyone anywhere can know. The corrupt file, as Early said in his email, was stored corrupted inside of the zip file that you uploaded. There is no charge for us to check out the files for you manually. But of course we have to know that there is a problem before we can fix it for you.

Sorry you have had no luck using our system. Please enjoy either rendercore or efxone. Thanks!

01-08-2004, 03:19 PM
Hi Panikos, dwburman

I've also found that Respower are good to deal with, always very professional and friendly.

If you do a search for 'respower' in the Lightwave Archives on CG Talk or the Newtek forums, you'll find more often than not, it's me recommending Respower to other users.

I was in a bad mood last night after spending what seemed like half an hour, trying to delete a file off the server. When I'm in a bad mood I like to share my frustration with others. I apologise for that.

I've been trying to delete this file (actually a folder with with previous projects) for several days and it just added to my frustration when other things went wrong. Not all related to Respower.

01-08-2004, 03:34 PM
Thanks earlye

I appreciate your help. I didn't expect to get a reply here from Respower, that's got to be good service :)

I'll try using another FTP client. Do you have any ideas why the same file is always ending up as currupt?

01-08-2004, 04:01 PM

Maybe it has to do with the you being on a Mac and ResPower more than likely is using all PCs?


01-08-2004, 04:10 PM
Hey Ricki -

Which ftp client are you using? Our mac users mostly use fetch FTP without much difficulty and don't have much troubles deleting by using the FTP....

I totally understand about being tired and upset about stuff... please let us know if you have a problem, we really will jump through hoops to help out. Hope there are no hard feelings regarding my previous post. And really, we'll even call you if necessary! But we need to know that there's a problem...

One of the things we are working on is a method to allow people to page our cell phones without incurring long-distance charges. The main trick is for us to ensure that we don't get spammed by our cell phones! We think that will be operational soon, however.

As for being on a Mac vs a PC, that typically isn't a problem. The only major difference between macs & PC's is the use of a different ASCII carriage return in the scene files. Otherwise the files are identical.

As for ground.lwo, it may just be a matter of doing a file / save as in order to clear out the corruption. We can't actually load the file ourselves.

01-08-2004, 04:30 PM
Thanks Respower, I fully understand you reaction, cheers, no problem. :)

I'm using Fetch 4.0.3 on OS10.1.5 with LW7.5c and ZipIt 2.2.2

I'll try 'Save As' and try to breaking the object down to isolate the problem.

Sorry for any grief I've casued. I will of course keep using and recommending Respower becuase I do think it's a great service.

01-08-2004, 04:38 PM
Hey ResPower,

Have you considering using MSmsg or any IM client that can use a webcam for support. It may only work well for broadband users but I and a friend tried it and it works pretty well.

Would be a way to contact you and talk in realtime and even see each other without the long distance phone charges for either party.

Well just a thought.


01-08-2004, 04:51 PM
We do use IM's on occasion, but they only help once the initial contact has been made... Unfortunately there's no clean, cheap way for someone to make the first contact, except to have some kind of paging system set up. Early's been working on the code for that, and we've just two days ago purchased new cell phones with unlimited text messaging to alert us when someone has a problem. The next step is to make a place on the site that would allow users to "page" us & get our behinds out of bed and log on to IM...

01-08-2004, 04:53 PM
Originally posted by riki
Thanks earlye

Not a problem. We're always glad to help. I noticed your comment about our not appreciating a phone call at 4:00 am. We've made our system self-service so you can render on your schedule instead of ours. Call whenever you like. Wake us up. No big deal - happens all the time. I'll catch up when the sun goes down in Australia.

Do you have any ideas why the same file is always ending up as currupt?

There are only 2 things I can think of:

1) maybe you're using a very old ground.lwo file that's still got the old Macintosh "resource fork" information in it and that's confusing LW on the PC. I'm not sure, because I've never seen a .lwo file from an old Mac OS/9, and for all I know you've never used OS/9. What I do know is that your .lwo file has about 128 extra bytes at the beginning before the normal LWO format begins, and those 128 bytes containing things like the filename (ground.lwo) and a bunch of binary data.

2) It's conceivable that ZipIt is tacking these bytes in front of the file. Again, I'm not sure, since we've not seen this with anyone else, even though we've got dozens of users that are on the Mac, but it is a possibility.

Ladd suggested doing a load/save cycle in modeler. You might also consider doing a load, copy-and-paste-to-new-file, and then save, just to force Lightwave into getting rid of the extra junk at the beginning.

Back to the delete thing. I'm pretty sure you said you were using fetch...

You were trying to delete a folder that had files in it, right? Is fetch able to delete a file in that folder right now? If so, I imagine that the actual problem is that fetch doesn't step into a folder and delete its contents before deleting the folder itself. Unfortunately, I don't know of too many other FTP clients for the Mac aside from using the command prompt to use the FreeBSD command-line ftp. I wouldn't advise going that route unless you love typing and actually enjoy command-line arcana. It wouldn't recurse your folders for you anyway.

01-08-2004, 05:25 PM
Thanks Early

I'll give those suggestions a try. I do have OS9, though it runs on an external Firewire Drive and just the bare essentails to run a few legacy APPS (Nothing LW related, just Government taxation stuff etc).

I'll try the load/save cycle and 'copy-and-paste-to-new-file'. I'll also try uploading just a test scene with only the ground.lwo

Fetch wasn't able to delete files inside that folder. Sorry I should've kept a record of the error message. I was able to delete zip files in my main parent directory though.

Will try those suggestions tonight, and see whatever FTP APPs I can find. Many thanks for your help.

01-08-2004, 09:14 PM
Hey Early and Ladd, it looks like the copy/paste trick worked, I swapped the new ground.lwo on the server it's renderring now, thanks for your help.

01-08-2004, 09:37 PM
aaah :) Did quite make it. Two fail counts. But got a bit further that time.


Scene loaded.

LightWave command: wait.

LightWave command: render.
Allocating frame buffers.
Allocating segment buffers.
Updating geometry.

Moving ground:Layer1 (1).

Moving shell_01:L1_Main.
Moving shell_02:L1_Main (1).
Moving shell_02:L1_Main (2).
Moving ground:Layer3.
Moving ground:Layer4.
Moving spine (1).
Moving skydome:L2_Dome.
Moving spine (2).
Moving ground:Layer5.
Moving ground:Layer6.
Moving space_ball.
Moving ground:Layer7.
Moving ground:Layer2.
Moving storm.
Moving roots (1).
Moving shell_01:L2_Cobwebs.
Moving rocks:Layer1.
Moving rocks:Layer2.
Moving rocks:Layer3.
Moving rocks:Layer4.
Moving rocks:Layer5.
Moving rocks:Layer6.
Moving rocks:Layer7.
Moving roots (2).
Moving ground:Layer1 (2).

Optimizing ground:Layer1 (1).

i 0 NODE220 2004-01-08 23:21:00 Optimizing shell_01:L1_Main.

Optimizing shell_02:L1_Main (1).

Optimizing shell_02:L1_Main (2).

Optimizing ground:Layer3.
Optimizing ground:Layer4.

Optimizing spine (1).

Optimizing skydome:L2_Dome.
Optimizing spine (2).
Optimizing ground:Layer5.
Optimizing ground:Layer6.
Optimizing space_ball.

Optimizing ground:Layer7.
Optimizing ground:Layer2.
Optimizing storm.
Optimizing roots (1).
Optimizing shell_01:L2_Cobwebs.
Optimizing rocks:Layer1.
Optimizing rocks:Layer2.
Optimizing rocks:Layer3.
Optimizing rocks:Layer4.
Optimizing rocks:Layer5.
Optimizing rocks:Layer6.
Optimizing rocks:Layer7.
Optimizing roots (2).

Optimizing ground:Layer1 (2).

i 0 NODE220 2004-01-08 23:25:28 Transforming coordinates.

Removing hidden polygons.
Computing polygon distances.

Sorting polygons.

e 0 2 NODE220 2004-01-08 23:26:56 Task processing failed:
Screamer exited (0xc0000005) while expecting Ready[0x80020009][Task Processor]
(std exception:_STL::runtime_error)

Looks like it's still having problems with the ground.lwo I'll tray again later. Some layers in that object, use Hyper Voxels. Not sure if it makes any difference??

01-09-2004, 06:14 AM
Hi Riki,

Sorry to have to expose Windows arcana to you, but...

Screamer exited (0xc0000005) while expecting Ready

This says that lwsn.exe stopped in the middle of its render. The exit code 0xc00000005 is a Windows "access violation" error, which means that lwsn.exe tried to touch memory that it did not have permission to touch, and so Windows killed the program.

We're looking into why that happened right now. Could be ground.lwo. Could be just about anything.

Hypervoxels should not be a problem, though - we render them all the time. However, it looks like you didn't bake the particle motion into a particle fx (.pfx) file. I don't think this would make your scene *crash*, but there's a distinct possibility that your particles will not show up where you want them to.

As a side tip, always make sure there aren't any frames where there's a voxel right on top of the camera, because for those frames, you'll see a render times that are unbelievably long.

Again, I'm sorry that you've hit a rough patch in our service, and I understand your frustration. We're always available to support you. I'll be sending you an email shortly with instructions on sending me a page so you can get in touch with me after hours without incurring long-distance charges.

01-09-2004, 06:23 AM
Thanks Early, I've just discoverred that layer 2 of Ground.lwo is corrupt. It's also causing Lightwave to crash on my machine. Luckily it was a relatively simple part of the object, just a flat plane. I've replaced the problem layer and it's renderring okay on my machine, also I've just uploaded a new version and going to test it now on Respower. I've isolated the problem down to that layer, keeping my fingers crossed :)

01-09-2004, 06:41 AM
Ricki -

Don't forget as well to save out your particle settings into ".pfx" files so that your hypervoxel particles won't flutter between frames. You'll want to save these pfx files into a "misc" folder within your content directory.

Particle movements are stored in the pfx files. If you have every computer on the render farm trying to generate those movements, then you'll end up with floating point imprecision between those movements (as well as slow down your rendering). Motion in LW is not integer based, it's floating point, so each computer will end up with different results (however small). That's why they built in the ability to save out the PFX file, which contains how many particles you have and where they are moving.

01-09-2004, 07:05 AM
Hi ladd, I have to do some high res print quality stuff next week. It's for the CG Challenge, so just a still image this time. I haven't baked any surfaces etc yet, just wanting to get some quick test renders as I finish the image.

Looks like I still didn't get it 2nd Fail Count. I might call it a night, see if I can work it out tomorrow.

Many thanks

01-09-2004, 07:22 AM
Hey Ricki -

We're going to load up your scene and see what the issue is. Also I'll try to be in the office earlier tommorrow about 5:00 am CST so we can IM and get this puppy straightened out.

01-09-2004, 07:28 AM
Many thanks for your help :) I really appreciate it. Speak to you soon


01-09-2004, 10:04 AM
Jeez, I hope you guys get this problem worked out. I have never had these problems myself. As many of you know, I have nothing but the utmost respect and praise for ResPower. These guys are fantastic and have pulled my butt out of the fire many a time. In fact, using ResPower has changed my entire work flow. Since I can render animations faster, I have more time for tweaking and modelling, thereby making my end product even better. My client and I both benefit from ResPower. Thanks guys. I would recommend their service to anyone. Hey, I had heard somewhere that you guys were going to put out a new interface for the site. Is that true? Can you reveal any details? I wish all of you wavers a prosperous new year and happy rendering.

01-09-2004, 10:08 AM
Nevermind. I just logged in to http://www.respower.com and noticed that you do have a new interface. It looks cool. I'm going to explore it now. Thanks!

01-09-2004, 04:56 PM
Hey Riki -

We took a deeper look at your scene file, there's something quite wacky there. You have 478 instances of the hypervoxels drawing plugin (found under Item Properties / Add Custom Object) applied to instance 1 of layer 1 of ground.lwo. Layer 3 of instance 1 has 24 instances. Instance 2 layer 1 has 237.

If I am not mistaken, this is probably not a good thing and is probably causing a serious problem. Was there any reason for adding so many different instances of the same plugin? They have no interface and end up converging into one under the hypervoxels interface anyway... (which I find as a shortcoming of LW design). It almost seems as if we've just found a new bug or something, where Lightwave is adding the HV drawing plugin over and over again every time you save, or something.

We can't seem to reproduce spontaneous, unintentional HV rendering instances. Is the file corrupt or was it intentional?

Anyway, we've pulled out all instances except one and are now running a test. Will check in with you in the morning (unless you need us sooner... give us a call if so!)

01-09-2004, 05:23 PM
Sounds like a typical bug - Riki, did you use the Spreadsheet manager at any time when working on your scene? I think you'll find it tends to occasionally spat itself and do odd things - Also duplicating itself on occasion several thousand times. See that amongst others in LightWave that always crashes our screamernodes.

Try my script LCSM that attempts to clean up a lot of issues (The 'optimise' tab has a Production cleaner that removes a lot of troublesome plugins as well). Its not finished yet (I have more tests to add yet to finish it), but it works for the main issues...


Is LScript for 7.5c - It should work fine on a Mac as well as a PC. But I won't guarantee that...

01-09-2004, 05:23 PM
Hi Ladd, thanks for pointing that out and taking the time to sort this out for me.

That's really bizarre, I didn't apply it 478 times. I know I'm obsessive but not that bad :)

Here's a copy of what the image should look like (PS ignore my sketch notes). I have three sets of One- Point-Polys, each containned on a seperate layers. I'm assuming LW would treat each layer as a seperate object. Not each point as a seperate object?? That's really odd I wonder what wrong??



01-09-2004, 05:27 PM
Thanks Kev

No I never use Spreadsheet. Thanks for the lscript will give it a burl.

01-09-2004, 05:34 PM

That seems like a relatively simple scene. You can't just render it on your machine?

How long does a single frame take and what kind/speed machine are you using?


01-09-2004, 05:45 PM
I've got a G4 400 it takes about 8 hours.

01-10-2004, 04:23 AM
Hey Riki -

Just drinking some coffee here and trying to wake up. The test still crashed (dangit) so here's a wrap-up of where we are + a couple of extra things to think about:

1) The HV instances may be causing the crashes;

2) The amount of subdivision on the nurb objects (Render Sub Patch Level 14) may be causing the crashes (might want to freeze them in modeler at that subdivision level and swap out the nurb version)

3) (Related to 2): We have noted that while nurbs are great tools for modeling and for character animation, your particular project is sort of half-way between organic and mechanical. It may be smart to not only freeze them, but to then use band-glue to reduce your poly count in strategic locations. Nurbs will put polygons into spots that aren't needed, slowing you down and causing difficulties such as in this instance.

4) We have noticed on occasion that single-point polys (as opposed to no-point-polys) can also cause crashes when combined with HV. Shouldn't happen, but lots of things shouldn't happen in LW. I'd recommend killing the single-polys and going with just points, if the single-polys have HV applied to them.

5) When you bounce back and forth between modeler and layout during your normal work flow, changing the makeup of the layers in modeler, there is a tendency for layout to get confused about the layers. It is always a good idea to have the layers for the model in Layout next to each other in the list. You can accomplish this by moving them up and down in the scene editor. Also, if any of your objects have unused layers (blank) you might want to remove those blank layers.

6) Endomorph Mixer - For a still are you sure you want to throw an extra element like this into the mix? Is there a less complex method of achieving the same result?

7) General Debugging Tip - Debugging a scene file is like debugging a computer program. First point of attack: simplify the number of potential failure areas. The more complex, the harder it is. This is a very complex scene. Whatever you can do to reduce the number of plugins, scripts, and other potential gotchyas, the better. It is a well-known axiom that the more complex a system, the greater the chances of failure.

8) Render Farm Workflow: you can do a work flow in which you can overwrite just objects or just scene files, etc. There is no need to constantly upload the whole kit and kaboodle every time. Many of our customers simply leave one set of files on the system and overwrite those that have changed. This may make it easier for you to track down the issue.

9) Single Frame rendering on a render farm: There are certain times in which single-frame rendering on a render farm is a good idea, and certain times when it is not. Your particular instance may be amenable to render farming, but there are certain things to note:

a) There is a limit to how much you can split the rendering before you start "going backwards" in wait time. I'd say for this project you'd want to do a 10x10 matrix, maximum. This limit is due to the fact that each computer must load up the scene, creating a bottleneck or "impenetrable barrier" of parrallelism.

b) There is a limit to how fast you can speed up a single image rendering because of this limit I mentioned in a). You may only see a 4 to 5 speed increase. The 8 hour rendering time you mention is a borderline case. You may be able to get it down to half an hour on our system. But you then need to balance that time saving against the time you are spending debugging your scene file. If it renders on your system in 8 hours without error, might not be a good idea to spend 12 hours debugging it on our system in order to get your rendering down to 1/2 hour.

We do have customers that render stills on our system, but typically they come to us when they have 24+ hour render times.

c) FLX file format: Should you decide that it makes sense to render the still on our system, depending upon resolution, you might be able to do this in the .flx format, so that you can mess with lighting and exposure after the fact, rather than re-rendering because the entire image was too dark or too light (see the image control features and the floating point viewer for information on HDRI stuff). The .flx file format is 128 bit floating point, and so stores the entire range of a Lightwave rendering. An added benefit of using the .flx is that you can then re-combine your tiles through our system, which can load the .flx buckets and put them back together again.

Anyway, some stuff to think about. Not in any particular order, but I am still waking up and haven't had enough coffee. Will be monitoring for a response here.

01-10-2004, 04:30 AM
Originally posted by riki
I've got a G4 400 it takes about 8 hours.

So you're saying it takes 8 hours to render 1 frame?

I get ancy if my render times exceed 5 minutes a frame but I typically render out lots of 1000 frame sequences on a big job.

My last animation job consisted of 10 seperate animations averaging about 800-2000 frames each and I was able to render it all on a 2.5 Ghz P4 within a week or so of overnight renders.

Man sounds like time to upgrade. :(


01-10-2004, 04:45 AM
Hey Js -

He's doing a still, not an animation... makes sense to get antsy on an 8 hour render time for a 1000 frame animation.

Your example is more suited to render farming. 1000 frames at 5 minutes a piece for one sequence equals a 5,000 minute wait time, or 83.333 hours. On our system, that would amount to roughly 1/2 hour of wait time.

If you're rendering for a week straight on one machine - or 24 x 7 = 168 hours, you could boil that down to appx. 1 hour or so.

Would cost about $200.

01-10-2004, 04:55 AM
Really only $200? I thought your service was more expensive.

I've gotten really good at optimizing my scenes. The 5 minute per frame I think I got down to under 2 minutes on the final.

Well I'm a self reliant kind of guy. Also if I need to make a change or rerender something I can do it right away.

Well also I do have 3Mbit broadband so uploading/downloading the files wouldn't be a problem.

It would be cool to render out 10,000 frames in about one hour. :D

I usually render at night while I sleep so I'm never waiting for anything. If I need to carry a render on through the day I will set Lightwave's priority to Low in XP and it allows me to render and work on other things simultaneously.


01-10-2004, 05:03 AM
Woah! Not 10,000.... 1,000...

10,000 frames at 2 minutes a piece would be:

On one computer:
20,000 minutes or
333.33 hours or
13.88 days

On our system (roughly):
80 minutes or
1 & 1/2 hours

For lightwave, we charge $0.50 per GHz hour. Each machine is 2Ghz. That means $1.00 per hour per computer. We only charge for the time the machine is actually working (not the in-between seconds that the computer is waiting to get a new frame), so that translates into about $200 an hour.

Primary advantage of using a render farm is that you can spend more time working on the animation & modeling. Basically you do a bunch of work, render on the farm, see the whole thing, then go back and tweak and render it all out again. You can pack a lot more quality in when you're not waiting a week for the final results.

01-10-2004, 05:20 AM
True but I usually render in pieces and composite it together.
That way if I have to change or rerender something I don't have to rerender everything.

Anyway I'll keep you in mind if I get up against a tight deadline.

My customers usually have loose deadlines for big projects but some may not.


01-10-2004, 05:40 AM
That's cool. We have a lot of customers who do compositing. Also lots of customers who use the .flx format... basically they'll do something like this:

1) Upload scene & files
2) Render low-res scene in layers for compositing (.tga format), download
3) Set up an AE project, get the layers set up with low-res .tga
4) Tweak & Render high res versions on render farm in .flx, download
5) Use LW to transfer 128 bit .flx to 24 bit tga files, with image control tweaks
6) Replace low res versions with the latest 24 bit tga's, do final composite in AE

01-10-2004, 06:06 AM
Hi Js33 yeah I need to upgrade but can't afford it now, and I might be moving overseas soon so I don't want to make any major purchases at the moment.

Thanks Ladd for the tips, I'm reading through them now, a lot f stuff there that I didn't think of before. I've taken this opportunity to rethink the work. Plus pushing a pretty tight deadline but hopefully will come up with something bigger and better.

It makes a lot of sense for me to use a Renderfarm. At the moment I'm just doing low res tests, but once I move up to print res there's absolutely no way my system could handle it.

Many thanks again Ladd

okay back to modeling :)

01-10-2004, 07:11 AM
Thanks again for the tips Ladd, that's awesome. I really can't thank you and Early enough. I'm going to take all this onboard with the next build. I'll do my test renders on Res, so hopefuly I'll be able to spot any problems as I go and avoid any issues getting out of control.

01-10-2004, 08:11 AM
No problems Rick! Let me know if you need anything else.

01-23-2004, 03:51 AM
I would simply like to say that ResPower has saved my butt on multiple occasions. Always helpful - they seem like they don't sleep which is a huge bonus when sending stuff from the UK!

Most of the projects I've rendered over ResPower have been stills - I think the largest was about 12k pixels high. We'ev uploaded plugins & really pushed the envelope when it comes to memory & cycle intensive projects.

I'm not saying that there aren't occasional problems, but talking from experience running my own renderfarm (much smaller - only 50GHz) that most of them stem from lame coding in LWSN. (I've been checking newtek.com twice a day for the last couple of months in the hopes of LWSN 8.0 being released. :P )

The improvement I'd most like to see is the installation of another gig of RAM on each of their nodes, but I don't think that would be particularly cost-effective for the majority of their clients. *sigh*

Once again - I can completely recommend ResPower to anyone needing a lot rendering done quickly. :)


PS: I have no financial interest in ResPower, except that I really appreciate their service & want to see them do well. :)

01-23-2004, 12:27 PM
I just started using Respower and it is great. I sent over a small test animation and it spat it back out in seconds for what took me 15-20 minutes to render at home. And it only cost me a few cents to do. This is looks great as a way to do D1 res renders with no problem.

This also make having a home renderfarm unneccessary. Which is a relief since it means I can give out some old computers as presents and get my office space back. :)


01-23-2004, 01:13 PM
Originally posted by claymation
This also make having a home renderfarm unneccessary. Which is a relief since it means I can give out some old computers as presents and get my office space back. :)

There you go. The ResPower Render Farm (http://www.respower.com/) not only saves you lots of time, it gives you quality of life :)

I'd like to say thanks to everybody who's chimed in with good reviews!

If you haven't already checked it out, we've got a free beta for a UV-mapping plug-in, Super/UV that can save you even more time. Check it out in the freebies section of our site.

Stay tuned, too - we've got an OS/X version of Super/UV on the way as well as the highly anticipated "hologram" project.

More power to you!

01-23-2004, 02:41 PM
Does Respower have the HD Instance plugin installed? I have a scene to render tha uses it.


01-23-2004, 02:48 PM
Sure do! I use it over here all the time on the render farm (http://www.respower.com) myself whenever I do animations!

02-16-2004, 01:32 AM
Hi Early and Ladd, I just solved this problem

When you create a folder in OSX it creates a hidden file called .DS_Store If you then upload that folder to an FTP Server (Such as Respower) you can't delete the directory at a later stage. It keeps returning an error message, that the directory isn't empty.

I needed to send an FTP command to delete the .DS_Store file before I could delete the directory.
I have also now set my upload preference to ignore dot files. Hopefully that will work.

02-16-2004, 06:30 AM
Hi Riki,

The FTP server is doing "the right thing" according to the FTP standard - that is, a delete on a folder requires that the folder is empty.

Granted, to us humans, that's a pain. Most FTP clients can hide this aspect of FTP from you by stepping into a folder and emptying it out before attempting to remove it, including dot files and folders.

It sounds like your FTP client isn't emptying out a folder before attempting to remove it or that it's failing to look for dot files while it does so.

You essentially have 2 options: empty the folder manually before trying to delete it, or find an FTP client that will step into the folder for you.

02-16-2004, 02:40 PM
Hi Early

I've noticed the same problem on a clients Web Server, so did a bit of digging and discoverred that Fetch has a Preferences Option which should fix things. At least it'll stop me from uploading the invisible DOT Files.

02-16-2004, 02:55 PM
Originally posted by riki
... Fetch has a Preferences Option ...

If Fetch does attempt to empty out a folder before attempting to delete it, it may be missing the dot files because you have "Send LIST -al to UNIX servers" turned off.

The -a option forces the server to include dot files/folders in its list, while the -l option forces the server to give a "long" output. It would be better IMHO for fetch to use ls -a (without the l) but that doesn't seem to be an option.

I don't know if this will make fetch delete dot files before removing a folder - but it might help.

02-16-2004, 03:17 PM
Thanks Early, I'll give it that a try.

The annoying thing with Mac OS X is that it no longer lets me create DOT files, like .htaccess files. Filenames that begin with a DOT are now reserved for the OS.

Anyway I'll save that one for another time. Many thanks for your help.

02-16-2004, 04:28 PM
Originally posted by riki
The annoying thing with Mac OS X is that it no longer lets me create DOT files, like .htaccess files. Filenames that begin with a DOT are now reserved for the OS.

Ouch! I know if you go through the trouble of installing the UNIX toolkits that come w/ Jaguar, you can create files with just about any name (including dot files), but you have to do it via a command line. Kind of counter to the whole Mac genre of computing...