PDA

View Full Version : Version compatibility report for scenes



SplittingPixels
01-07-2004, 02:17 PM
It would be great if you could have LW do a backwards-compatibility check on a scene for older versions of LW and generate a report on "problem features" that will break the scene on older software.

For example, Sliders, the SpreadSheet, or SasLite would be reported as definite problems if the target software is LW 6.0. In the case of third-party plugins, you would automatically need to flag every one (for the simple fact that there is no guarantee that the target systems will have them available), and raise the warning-level for any plugin that requires a more recent version of LW than the specified target version. (I may be mistaken, but I believe that most properly-written plugins and L-Scripts have version information included, so this should be possible.)

The object file format hasn't changed since 6.0, so that's probably not a concern, unless it changes in the next update... :)