View Full Version : vertex colours

05-13-2019, 04:41 AM
anyone had any luck seeing vertex colours in modeller and getting vertex alpha & vertex colours to export to fbx successfully? in this case, trying to goto unity

05-13-2019, 06:43 AM
which version of Lw are you using? In LW 2015 fbx export does not support vertex colors or vertex normals or smoothing groups. I think it supports normals and smoothing groups in the latest version but not sure about vertex colors.

05-13-2019, 07:31 AM

05-13-2019, 08:03 AM
Ok, I don't have that version so I don't know how that works. I know that if you export fbx from blender then you get vertex colors with the model. Maybe you can use OD copy and paste external to Blender and export the model from there? Or vertex paint it in Blender as well as I think the vertex paint environment is a little bit nicer in Blender than in LW.

05-13-2019, 08:14 AM
yes i was considering that. i used max this time round.

it sucks having to jump out of lw for something so basic

05-13-2019, 08:25 AM
Blender also supports vertex color alpha as do 3dsmax. I just suggested Blender as its free and everyone can use it.
Yeah, that is why I started to use other 3D apps more than Lw as I'm tired of waiting for all small basic things to get fixed.

05-13-2019, 03:58 PM
yeah no problem. i was going to go the blender route, will try this out. Workflow is far superior to LW


05-14-2019, 09:45 AM
I'm pretty sure they are visible, and can be imported and exported, in 2018 /2019, I tested it a few times. hmmm.

05-14-2019, 04:13 PM
yeah i’ve had no luck, if you get it to work let me know. i tried blender 2.8 but is see no way to paint vertex alpha there either. max worked the best atm.

05-14-2019, 05:12 PM
I don’t know if it works in 2.8 as it is still in beta, but it works in 2.79c. You paint alpha by taking the substract brush with a black color and just paint.

Areyos Alektor
06-02-2019, 02:11 PM
As you talk about the Modeler I assume that there is no rig on it ? Because in this case you can use this :


Otherwise you tried with the Unirty package ?