View Full Version : Sliders deactive once I leave frame 0. Help!!!

04-08-2019, 07:37 PM
Hi Folks.

Well this is a weird one... When I go to animate any object with Sliders on it, the sliders as you can see are available for use on frame 0, but once I leave that, frame 1, 2, 10, 100, 1000, etc., the sliders become deactivated and are totally unavailable. I have checked this on my desktop computer and laptop and it's happening on both, with any scene file I load. Anyone got any ideas because I've never seen this before?

04-08-2019, 07:51 PM
Oh my God, I just did a test. Create a cube, layer 1. Copy to layer 2. Save.

Go into Layout. Parent layer 2 cube to layer 1 cube. Select layer 1 cube. Add Sliders control in Properties. Set up a basic rotate layer 2 cube control.

When on frame 0, it is available for use. When I move to frame 1 it becomes unavailable. Trying to think what could be causing this and the fact it's happening on every scene on both machines, the only thing I can think of is a recent Windows update that both computers got. Please don't tell me this has messed this all up on me! Is there any way to fix this? Am I missing something obvious?

04-08-2019, 10:27 PM
Works fine for me in LW2015.3, Win64 as from your screen capture. Scene attached. Are you accidentally hitting SPACE and disabling the Sliders? Does CTRL-D work to re-enable them if you're off of Frame 0?


04-09-2019, 03:35 AM
Paul, from your images it looks like they only highlight on a keyframe (f0) but when moved to where there isn't a keyframe the slider greys out.

Hope this helps :)

04-09-2019, 04:46 AM
Like daforum says, they light up to indicate the presence of a keyframe, they havent deactivated.

04-09-2019, 05:19 AM
Thanks very much for the help, folks. I've done some testing and I think I've found a problem.

First, you're right, the sliders do dim when not on a keyframe, sorry about the confusion there. But look at this image here:


The slider controls of Prizonian 1's left hand have disappeared completely. When I got into Properties -> Sliders, all the controls are gone.

So I then took the test file above and I did a test... I Clone Hierarchy on the two boxes and look:


All the sliders end up linked together but only the original box turns. I think the Clone Hierarchy tool and Sliders don't work well together, at least in Lightwave 2015. I can still do my renders in these scene, but I'll have to keep this in mind for future use where I need multiple copies of a character.

Thanks for all the help, much appreciated.

04-09-2019, 06:07 AM
what if you import a character from scene instead of using clone hierarchy, will that fix the problem ? I recall it fixes a problem for some other issues.

04-10-2019, 07:18 AM
That worked. When I love each copy individually from file, the slider controls are fine. Thanks for that.

04-10-2019, 01:52 PM
That worked. When I love each copy individually from file, the slider controls are fine. Thanks for that.

Can someone with LW2019 please test and confirm/deny whether the above problem still exists?

If so, it really needs to be reported -- that behavior suggests "clone hierarchy" is actually corrupting cloned hierarchies, and such corruption would also likely be responsible for other issues/failures.