PDA

View Full Version : LWB-4868 LightWave Bridge to Unreal Engine..(flip the Green channel in Unreal)



aperezg
03-05-2019, 03:59 PM
Hi...
This is the bug that corrected, in new version 2019.0.2
LWB-4868 LightWave Bridge to Unreal Engine: Respect Y Flip setting in the NormalMap node to flip the Green channel in Unreal.

in version 2019.0.1 LightWaveBridge worked fine in all the images, even normal maps.

In this new version 2019.0.2 LightWaveBridge flip the green channel in all images including Normal Map.

Every time that I send images to Unreal, i have to open each image and uncheck, flip green channel for those images.

I try to use LightWaveBridge version 2019.0.1 with version 2019.0.2, but layout close, unexpectedly.

NewBug report.
(LWB-4914) Light Wave Bridge to unreal engine flip the green chanel

Deep Purple
03-06-2019, 04:28 AM
Sorry for letting that bug slip through, it is fixed and will be part of the next bugfix release.

- David

gar26lw
03-06-2019, 08:49 AM
Sorry for letting that bug slip through, it is fixed and will be part of the next bugfix release.

- David

hey, nice one David. thanks for dropping by and good stuff with unreal bridge :)

aperezg
03-06-2019, 12:54 PM
Sorry for letting that bug slip through, it is fixed and will be part of the next bugfix release.

- David

Thank you for your job.
I will be attentive the next compilation.

rustythe1
03-06-2019, 01:15 PM
looks like something similar is happening with standard images too, cant seem to fix it as you cant flip standard srgb values back but see in this grab, seems there is something going on with the red and green channels here too,
144344
the pink should be beige and the wood is yellow so looks like its got green instead of red, even if you reimport the asset manually, oddly it doesn't always happen until you restart unreal or make some surface changes, i.e. initially the image is loaded correctly on first import,

aperezg
03-06-2019, 04:53 PM
looks like something similar is happening with standard images too, cant seem to fix it as you cant flip standard srgb values back but see in this grab, seems there is something going on with the red and green channels here too,
144344
the pink should be beige and the wood is yellow so looks like its got green instead of red, even if you reimport the asset manually, oddly it doesn't always happen until you restart unreal or make some surface changes, i.e. initially the image is loaded correctly on first import,

in the image editor, flip green channel, the little square is marked.
uncheck it

rustythe1
03-07-2019, 12:25 AM
oh yea, for the life of me I couldn't see it before but its clearly there in the screen grab!