View Full Version : 2015.3 license problem

01-19-2019, 03:19 AM
I haven't used LW 2015 in a while but I tried to recently and I got the license splash screen like when you first install. Except it says "The licensing system found one or more license files, but could not detect any usable license keys". So I drag and drop my LWK file onto it as usual, it says the file was added as usual, then I restart and get the same splash screen. Any idea how to fix it? I'm working on making a tutorial and will need 2015 for one part.


01-19-2019, 09:03 AM
I just very recently experienced the same - there was no other LWK on that machine, did a search for it and got no results yet it presented me with that error. It turned out there was a rather old past installation on that system which apparently was not uninstalled properly. I let the LW-Uninstaller do its magic restarted the system and did another clean new reinstall of 2015.3 after that it worked...

01-19-2019, 11:20 AM
FYI, I have LW2015 and LW2018 installed (all point versions) and they both work (on mac).

01-19-2019, 04:27 PM
I wrote to customer support but didn't expect to hear back until Monday or Tuesday. I actually heard shortly after writing. I haven't tried it yet but it sounds like a pretty easy fix.

Step #1: Launch a Command Prompt with Administrator Privileges
Step #2: Change Directory to the LightWave 3d bin Folder
Step #3: Type configure unset and Hit Enter
Step #4: Type configure set and Hit Enter

04-10-2019, 02:25 PM
Ugh, I just upgraded to LW 2019 and had this happen again. This time the steps didn't work. It still says it found a license file but no usable license keys. This is a brand new install of Windows after my old laptop hard drive died and was replaced. I do have LW 2018 installed. Maybe I'll have to uninstall it and try again.

Edit: OK I uninstalled every version of LightWave from this computer, rebooted, installed 2019 again, tried the Command Prompt steps again, and still no luck. I hope new users don't have to go through this, it would not give a good first impression.

04-10-2019, 09:04 PM
Problem solved and you'll probably laugh. I had to download the LWK file for LW 2019. This was never a problem before. I've been using the LW 11 LWK file for years.

Edit:Nope I was wrong. It worked once then after restarting it stopped again. Curiously if I open one (Layout or Modeler) and get the error I can open the second one and the second one will be fine.

04-11-2019, 02:26 AM
A wild guess: are you starting Lightwave from a shortcut that points to different folders (be it on your workstation or another location) than the default installation directories?
Happened to me as I was used to have older versions to start in/target the *.exe´s on a network drive

04-11-2019, 02:34 AM
Well, I'm just starting it from whatever it put on the Start menu. I can try clicking directly on the exe file and if that works make new shortcuts right from that. For now I found a workaround. I can use my old USB dongle, but I'd rather not carry it around with me in case it gets lost.

04-11-2019, 02:41 AM
Well thats odd... Did you get that info to support? I find it strange that the license works with a dongle but not how the newer builts are intended to be.
Have searched the C:\ for any *.LWK files? If there is more than one?

04-11-2019, 03:08 AM
Oh hey I did have more than one so, rather than just deleting the extras, I put them all in a zip folder so LW wouldn't find them. That seems to have done the trick. Oh wait. It worked once but when I closed and opened it again I still got the error. I did another LWK search and still just found one. I haven't told support about the dongle yet but I've been talking to them. I should mention that. Thanks.

04-11-2019, 06:09 AM
I ran into this issue when I first installed 2018 with a dongle free license. It turns out you can't have the dongle plugged in and have a dongle free license active for LightWave at the same time. I removed the dongle and all was fine. Not sure if this still holds true, but worth a try. Problem is, if you have plugins that require the dongle, they won't work.

04-11-2019, 11:38 AM
My dongle has been plugged in for about 10 years.
All recent LW versions, I have dropped the LWK file onto splash screen without issue, with the dongle attached.

04-12-2019, 07:57 AM
As I've mentioned before, when I install a new version of LW I try *once* to drag-n-drop the LWK file to the splash screen and restart Layout. If it doesn't work, I just copy the LWK file to the appropriate license location (which is really all the splash screen does).

The license location on Windows (per LW version, of course) is:



04-12-2019, 08:25 AM
From my experience it seems as if certain computers have the Lightwave license issue and others don't. My main laptop, a Lenovo Yoga 2 Pro, has NEVER been able to run LightWave without throwing me in Discovery mode.

Whereas every other computer I have (laptops and desktop), including my Surface Go, all load all versions of LightWave without a problem. My Yoga 2 Pro is the only problem child and I have to do Kat's command prompt set/unset trick every time in order to get it to load properly.

04-12-2019, 12:10 PM
I stopped using the dongle as soon as they allowed it, plus of course I use LW on my desktop and laptop so it meant constantly moving the dongle. Not good for wear and tear.
I've tried manually placing the LWK in the folder when dropping it didn't work. I did see that dropping it added a copy to the folder but I tried doing it manually anyway.
I also tried set / unset multiple times both manually and with the buttons on the Start menu.

07-26-2020, 04:29 PM
Where is the license location with LW 2020?

Nevermind. I found the path "C:\Users\username\.NewTek\LightWave\2020.0.2\licen ses"