PDA

View Full Version : 2015.3 interface



sebrady
01-16-2019, 06:21 PM
my MacBook Pro died March 2018. Just reinstalled my Lightwave 2015.3. Man, what happened to the interface. 1) Can I get rid of all the black icons everywhere. 2) How do you save a rendered frame. Used to be so easy, now I cant figure out how to do these things. Thanks.

143877143876[/ATTAC[ATTACH=CONFIG]143876143876143876H]

jwiede
01-16-2019, 06:26 PM
That problem you're seeing is an incompatibility with Mojave (10.14) and only LW2018 has been updated with the hotfix required. Chuck suggested that a hotfix for LW2015 is unlikely (see Chuck's posts in this thread (https://forums.newtek.com/showthread.php?158132-Don-t-upgrade-to-MacOS-Mojave-yet!-Update-Hotfix-Released)).

raymondtrace
01-17-2019, 04:23 AM
While "voiding your warranty", has anyone tried downloading the 2018 hotfix and using a hex editor to replace the handful of "2018.0.7" internal references with "2015.3"?

sebrady
01-17-2019, 02:53 PM
I have been out of the Lightwave loop for a while, so when would a "real" LW update happen, or should I do the "hot fix" now?
That problem you're seeing is an incompatibility with Mojave (10.14) and only LW2018 has been updated with the hotfix required. Chuck suggested that a hotfix for LW2015 is unlikely (see Chuck's posts in this thread (https://forums.newtek.com/showthread.php?158132-Don-t-upgrade-to-MacOS-Mojave-yet!-Update-Hotfix-Released)).

jwiede
01-17-2019, 03:15 PM
While "voiding your warranty", has anyone tried downloading the 2018 hotfix and using a hex editor to replace the handful of "2018.0.7" internal references with "2015.3"?

The hotfix was for 2018.0.6, by 2018.0.7 it was incorporated into the main package.

Also, the hotfix is just a replacement DLL/dylib (libtools). Trying to backport a much newer DLL into a prior _version_ of LW is asking for all sorts of trouble, though. Even if the dylib only contains plugins (which'd be about the most "compatible" case in this scenario), the plugin code will still be passing the wrong plugin API versions for LW2015 -- unfortunately, the hex editing needed to fix that is a bit more complicated than changing "2018.0.6" to "2015.3".

I do not in any way recommend or support attempting such modifications, or using a so-modifed LW2015 package. If you insist on doing so, please be very, very careful not to access any content you value/care about with such a modified LW2015 package. Also, definitely use clean configs, or else use a _copy_ of your LW2015 config files. Do not let it overwrite (thus likely corrupt) your only copy of "good" LW2015 config files.

sebrady
01-17-2019, 03:27 PM
Might as well upgrade to the latest version, Newtek tells me it will cost $300. Lightwave has always been stable for me from my beginning in 2003. Thank you very much for all your help.

Tim Parsons
01-17-2019, 08:22 PM
Might as well upgrade to the latest version, Newtek tells me it will cost $300. Lightwave has always been stable for me from my beginning in 2003. Thank you very much for all your help.

You won't regret it. The rendering engine is fantastic.